Project

General

Profile

Bug #9954

status_ipsec.php: Unable to manually connect P2 when P1 is up but not P2

Added by Jim Pingle about 2 months ago. Updated about 1 month ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
12/06/2019
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:
All

Description

On status_ipsec.php, if IKE (P1) is up but Child SAs (P2s) are not connected, there is no way to connect them without first disconnecting IKE.

This is already fixed on 2.5.0 (c6220dcf7faf3492713c6c30bb86d3971b2772a9) and 2.4.5 (7ba6c13bc644f6c1788e00802efb9d8b7b919edf), adding this for tracking. In both cases, a "Connect Children" button is now available on status_ipsec.php in the problem case which will initiate a connection for the children.

History

#1 Updated by Jim Pingle about 1 month ago

  • Status changed from Feedback to Resolved

Button behaves as intended on 2.4.5.a.20191217.0637

If I manually disconnect all IPsec children, the button appears. Clicking the button results in the children connecting. No need to disconnect/connect the IKE session.

Also available in: Atom PDF