Project

General

Profile

Bug #1003

captive portal not forwarding

Added by Dan Emmons over 10 years ago. Updated over 10 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Squid
Target version:
-
Start date:
11/09/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

Using pfSense-2.0-BETA4-20101109-0201 and pfSense-2.0-BETA4-20101104-0049

Configured captive portal for MAC bypass mode (router between users and pfsense)

Used known good html "welcome/auth" page (pulled from working PF1.2.3)

"View current page" redirects to pfurl:8000 but cannot connect

From a DNS forward client can see the "welcome/auth" page but nothing is processed.

Can see pfsense connect outbound on 53, ntp, but not 80 AT ALL.

Is squid broken?

History

#1 Updated by Chris Buechler over 10 years ago

  • Status changed from New to Rejected

duplicate of #868

#2 Updated by Dan Emmons over 10 years ago

I should add that squid isn't running, and is not configured.

output from netstat looks like its binding tcp8000 on LAN nic and attempting to connect outbound but packets don't leave the box...

Proto Recv-Q Send-Q Local Address Foreign Address (state)
tcp4 0 0 166.98.6.30.8000 192.168.28.21.49481 TIME_WAIT
tcp4 0 0 111.221.16.219.https 192.168.28.21.49480 ESTABLISHED
tcp4 0 0 iy-in-f105.1e100.8000 192.168.28.21.49478 ESTABLISHED
tcp4 0 0 iy-in-f105.1e100.8000 192.168.28.21.49477 TIME_WAIT
tcp4 0 0 iy-in-f105.1e100.8000 192.168.28.21.49476 TIME_WAIT
tcp4 0 0 111.221.16.219.https 192.168.28.21.49474 ESTABLISHED
tcp4 0 0 111.221.16.219.https 192.168.28.21.49473 ESTABLISHED
tcp4 0 0 166.98.6.30.8000 192.168.28.21.49472 TIME_WAIT
tcp4 0 0 hrasense.hosts2-ns 146.9.50.244.2405 TIME_WAIT
tcp4 0 0 localhost.8000 .* LISTEN
tcp4 0 0 hrasense.ssh 146.9.50.244.1929 ESTABLISHED
tcp4 0 0 *.hosts2-ns *.
LISTEN
tcp4 0 0 .domain *. LISTEN
tcp4 0 0 .ssh *. LISTEN
tcp6 0 0 .ssh *. LISTEN
udp4 0 0 146.9.70.220.52112 www2.bitvector.o.ntp
udp4 0 0 146.9.70.220.28757 morose.quex.org.ntp
udp4 0 0 .* *.
udp4 0 0 .domain *.

#3 Updated by Dan Emmons over 10 years ago

..and have tried both workarounds per #868

Also available in: Atom PDF