Project

General

Profile

Bug #10152

Squid: "unexpected operator" error in squid rc script

Added by Stefano Mereghetti over 1 year ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Squid
Target version:
-
Start date:
01/03/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.4.5
Affected Architecture:
All

Description

Hello
with the last merge of Squid pkg for pf 2.4.5, if I do a manual restart using GUI interface, the service doesn't start.

Jan 3 10:36:35    php-fpm    5703    /rc.filter_configure_sync: [squid] Installed but not started. Not installing 'pfearly' rules.
Jan 3 10:36:31    php-fpm    5703    /rc.filter_configure_sync: [squid] Installed but not started. Not installing 'nat' rules.
Jan 3 10:36:28    check_reload_status        Reloading filter
Jan 3 10:36:27    Squid_Alarm    82754    Reconfiguring filter...
Jan 3 10:36:24    Squid_Alarm    79826    Attempting restart...
Jan 3 10:36:24    Squid_Alarm    79661    Squid has exited. Reconfiguring filter.
Jan 3 10:35:25    check_reload_status        Reloading filter
Jan 3 10:35:24    php-fpm    32652    /pkg_edit.php: [squid] Starting a proxy monitor script

From console:

[2.4.5-DEVELOPMENT][admin@local.lan]/root: /usr/local/etc/rc.d/squid.sh stop
[: /bin/ps auxw | /usr/bin/grep [s]quid: unexpected operator
[2.4.5-DEVELOPMENT][admin@local.lan]/root:
[2.4.5-DEVELOPMENT][admin@local.lan]/root: /usr/local/etc/rc.d/squid.sh start
[: /bin/ps auxw | /usr/bin/grep [s]quid: unexpected operator

If I reboot the PF, the service start.

Regards

History

#1 Updated by Jim Pingle over 1 year ago

  • Project changed from pfSense to pfSense Packages
  • Subject changed from Squid service failed to start after a manual stop to Squid: "unexpected operator" error in squid rc script
  • Category set to Squid
  • Target version set to 2.4.5
  • Affected Version set to 2.4.5
  • Affected Architecture All added
  • Affected Architecture deleted ()

#2 Updated by Viktor Gurov over 1 year ago

Stefano Mereghetti wrote:

Hello
with the last merge of Squid pkg for pf 2.4.5, if I do a manual restart using GUI interface, the service doesn't start.

[...]

I can't reproduce the issue - pfSense 2.4.5.a.20200102.0720 and squid 0.4.44_12
start/stop/restart using WebGUI works fine

any specific options in squid?

#3 Updated by Stefano Mereghetti over 1 year ago

No particural configurations have been placed.
I tried with and without MITM config, standard and no custom settings.

If I uncheck the flag “Check to enable the Squid proxy” + Save, the service stop correctly.
If I check it, it starts without problems.

But, if I stop and start manually the service using the buttons in the top of the page, it fails.

Regards

#4 Updated by Stefano Mereghetti over 1 year ago

Hello
With the last merge and in a new fresh install... no issues.

#5 Updated by Jim Pingle over 1 year ago

  • Status changed from New to Resolved
  • Target version deleted (2.4.5)

Also available in: Atom PDF