Project

General

Profile

Bug #10208

incorrect range aliases creation if type is network(s)

Added by Viktor Gurov about 1 month ago. Updated about 1 month ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Aliases / Tables
Target version:
-
Start date:
01/25/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

On the page Firewall \ Aliases \ Edit
If you select the Network(s) Type and enter ip range (i.e. 192.168.1.1-192.168.1.10)
it creates an invalid list:

192.168.1.1/32
192.168.1.2/31
192.168.1.4/30
192.168.1.8/31
192.168.1.10/32

History

#1 Updated by Jim Pingle about 1 month ago

  • Status changed from New to Not a Bug

That is valid and correct. It made a set of CIDR networks which cover the range you requested, which did not align to CIDR boundaries.

Also available in: Atom PDF