Project

General

Profile

Actions

Bug #10233

closed

jquery-ui theme files missing

Added by Dean Olivas almost 2 years ago. Updated almost 2 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
Web Interface
Target version:
Start date:
02/05/2020
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5
Affected Architecture:
All

Description

I am seeing this error in the system log after updating this evening to 2.4.5.r.20200204.1736

If I change back to the light theme the error is gone.

2020/02/05 02:45:45 [error] 70683#100400: *1 open() "/usr/local/www/vendor/jquery/jquery-ui/themes/dark-hive/theme.css" failed (2: No such file or directory), client: 10.10.1.10, server: , request: "GET /vendor/jquery/jquery-ui/themes/dark-hive/theme.css HTTP/2.0", host: "10.10.1.1:10443", referrer: "https://10.10.1.1:10443/css/pfSense-dark.css?v=1578072823"

Actions #1

Updated by Jim Pingle almost 2 years ago

  • Subject changed from Dark Theme error to jquery-ui theme files missing
  • Category set to Web Interface
  • Assignee set to Jim Pingle
  • Target version set to 2.4.5
  • Affected Version set to 2.4.5
  • Affected Architecture All added

Looks like a few different jquery-ui themes were removed when we updated jquery ( #9407 ): dark-hive and smoothness

smoothness doesn't appear to be referenced by anything in the base system, but dark-hive is still needed for pfSense-dark:

usr/local/www/css/pfSense-dark.css:@import url("/vendor/jquery/jquery-ui/themes/dark-hive/theme.css");

The theme is still available for our current version of jquery-ui (1.12.1): https://code.jquery.com/ui/1.12.1/themes/dark-hive/jquery-ui.css

Actions #2

Updated by Jim Pingle almost 2 years ago

The pfSense-dark-BETA theme does not include that file, however. So we have a couple choices:

1. Add the dark-hive theme back, and fix the reference to it in /usr/local/www/css/pfSense-dark.css to point to wherever we put it
2. Retire the current "pfSense-dark" theme in favor of the "BETA" theme.

There are some visual differences between them that may not be ideal (especially font sizes in places like the dashboard), so I'm leaning toward option 1.

Actions #3

Updated by Jim Pingle almost 2 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Dean Olivas almost 2 years ago

Thanks Jim,

I can confirm problem is fixed with update 2.4.5.r.20200205.0809

Actions #5

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF