Project

General

Profile

Bug #10438

Prepare pfSense-upgrade to deal with pkg 1.13.x+

Added by Renato Botelho 3 months ago. Updated 2 months ago.

Status:
Feedback
Priority:
High
Category:
Upgrade
Target version:
Start date:
04/06/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

pkg 1.13.x bumped repository meta version from 1 -> 2 and older versions can't read new repo metadata.

Change pfSense-upgrade script to detect this scenario trying to download a meta.conf file from remote repo. When remote repo version is 2 and pkg is < 1.13 force it to bootstrap.

History

#1 Updated by Renato Botelho 2 months ago

  • Status changed from New to Feedback

Done

Also available in: Atom PDF