Project

General

Profile

Bug #1061

Error after upgrade to latest version

Added by Dienis Rastegaeff over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Unknown
Target version:
Start date:
12/01/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

/diag_tables.php show nothing in dropdown menu
AND
Filter Reload Status
"There were error(s) loading the rules: /tmp/rules.debug:84: syntax errorpfctl: Syntax error in config file: pf rules not loaded - The line in question reads [84]: block in log quick proto tcp from to any port label "webConfiguratorlockout" ..."

History

#1 Updated by Ilias-Dimitrios Vrachnis over 8 years ago

I can confirm this too.
I'm currently downloading an older snapshot to test.
i'll report back if i'm successful

current info:
2.0-BETA4 (i386)
built on Wed Dec 1 00:10:11 EST 2010

#2 Updated by Jim Pingle over 8 years ago

  • Status changed from New to Feedback

Should be fixed in the next new snapshot. In the meantime if you go to System > Advanced, on the admin tab, and explicitly set the GUI port to 443 and protocol to https, it should work. See 893f478 and also 50c352669d76f984f3c5269a0359120e3560f837

#3 Updated by Ilias-Dimitrios Vrachnis over 8 years ago

I had https, but i hadn't used 443 explicitly.
Nevertheless, pfSense-Full-Update-2.0-BETA4-20101130-0828.tgz was the file that made it all good for me again.
You can download it from http://snapshots.pfsense.org/FreeBSD_RELENG_8_1/i386/pfSense_HEAD/updates if you are stuck with that problem.

Because pf couldn't start, i could not see the outside world from my lan.
My workaround to download the tgz is this:

ssh -D 7070 admin@<router-ip>

and then use localhost:7070 as a SOCKS5 proxy with the web browser to download the neccesssary downgrade.

#4 Updated by Ermal Lu├ži over 8 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF