Bug #10671

pfsense 2.4.5_1 does not boot on Gen2 2012R2 HyperV VM

Added by Jan de Groot 10 months ago. Updated about 2 months ago.

Operating System
Target version:
Start date:
Due date:
% Done:


Estimated time:
Affected Version:
Affected Architecture:
Release Notes:


After upgrade to 2.4.5_1, the boot fails with Input/Output error when loading the kernel. Tested on 2 VMs, both suffer this problem.
Booting kernel.old works fine. The kernel shipped with 2.4.5_1 is much larger than 2.4.5, probably the loader can't load it in the EFI environment

Related issues

Has duplicate Bug #11469: Pfsense 2.5.0 not working with Generation 2 Hyper-V VMDuplicate2021-02-19


#1 Updated by Ernesto Rey 8 months ago

Stumbled into the same issue.

#2 Updated by Ernesto Rey 8 months ago

The old kernel can be booted as Jan stated by entering

boot kernel.old

when system is stuck in bootloader.

My workaround for now is to temporay restore the kernel.old to kernel:

  1. cd /boot
  2. mv kernel kernel.broken
  3. cp -a kernel.old kernel

Rebooting the system works now.
Haven't noticed any issues when running with the old kernel,
but for sure this is suboptimal and issues might occur.

#3 Updated by Jeff Munk 6 months ago

I have the same issue with Hyper-V under Windows Server 2019. I had to roll back to 2.4.4 (that was the latest .iso I still had as you don't allow download of past versions). I was able to get it to boot a couple of times by re-loading the menu (After it fails to boot type "menu" then enter), then that stopped working. Then I tried booting kernel.old and that worked once, then stopped working for some reason. The I had got it to boot that first time I had dumped the config so I just re-installed 2.4.4.

#4 Updated by Jan de Groot about 2 months ago

This also applies to pfsense 2.5.0. Also stalls on boot with input/output error.

#5 Updated by Jim Pingle about 2 months ago

  • Has duplicate Bug #11469: Pfsense 2.5.0 not working with Generation 2 Hyper-V VM added

Also available in: Atom PDF