Project

General

Profile

Actions

Bug #1068

closed

RRD Graphs not working on 64Bit Beta 4

Added by Shannon McMahon over 11 years ago. Updated over 11 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/03/2010
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

Installed build:

2.0-BETA4 (i386)
built on Thu Dec 2 09:23:11 EST 2010

Since install, RRD Graphs error:There has been an error creating the graphs. Please check your systemlogs for further details.

Saw this in the log:

php: /status_rrd_graph_img.php: Failed to create graph with error code 1, the error is: ERROR: This RRD was created on other architecture/usr/bin/nice -n20 /usr/local/bin/rrdtool graph /tmp/system-processor.rrd-day.png --start 1291269600 --end 1291350422 --vertical-label "utilization, number" --color SHADEA#eeeeee --color SHADEB#eeeeee --title "`hostname` - System :: Processor - 1 day - 5 minutes average" --height 200 --width 620 DEF:"user=/var/db/rrd/system-processor.rrd:user:AVERAGE" DEF:"nice=/var/db/rrd/system-processor.rrd:nice:AVERAGE" DEF:"system=/var/db/rrd/system-processor.rrd:system:AVERAGE" DEF:"interrupt=/var/db/rrd/system-processor.rrd:interrupt:AVERAGE" DEF:"processes=/var/db/rrd/system-processor.rrd:processes:AVERAGE" AREA:"user#990000:user" AREA:"nice#a83c3c:nice:STACK" AREA:"system#b36666:system:STACK" AREA:"interrupt#bd9090:interrupt:STACK" LINE2:"processes#cccccc:processes" COMMENT:"\n" COMMENT:" minimum average maximum current\n" COMMENT:"Use

Actions #1

Updated by Jim Pingle over 11 years ago

  • Status changed from New to Rejected

You aren't running a 64-bit snapshot. You probably accidentally applied a 32-bit (i386) update after installing the amd64 version initially. The RRD graphs cannot switch between 32 and 64 bit, they need to be removed and recreated.

Actions #2

Updated by Shannon McMahon over 11 years ago

Thanks. Although, it wasn't terribly intuitive when the firewall said there was an available update... I would think i386 builds wouldn't show up on 64 installs.

I backed up the config, and reloaded. RRD seems good now.

Thanks.

Actions

Also available in: Atom PDF