Project

General

Profile

Bug #10745

crashes/panics in pfsense 2.4.x FreeBSD 11.x with enabled IPSec and ipv4 forwarding

Added by Igor G 25 days ago. Updated 17 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
IPsec
Target version:
-
Start date:
07/09/2020
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

please this forum thread:
https://forum.netgate.com/topic/151329/pfsense-active-carp-member-crashed-aesni_process-crypto_dispatch

and this FreeBSD ticket with the fix
https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=246951

these crashes seem to be caused by refcount leak. only FreeBSD 11.x seems to be affected.

just wanted to create a ticket so that we can track if/when the fix from FreeBSD will make it to pfsense 2.4.x , such that we can switch from OpenVPN back to IPSec (before 2.5.x becomes fully stable).

thank you!

History

#1 Updated by Luiz Souza 17 days ago

  • Status changed from New to Resolved

This fix is already merged in our tree.

Thanks!

#2 Updated by Igor G 17 days ago

Luiz Souza wrote:

This fix is already merged in our tree.

Thanks!

can you please specify in which version of pfsense this fix will be available?

thank you!

Also available in: Atom PDF