Project

General

Profile

Actions

Bug #10875

open

PPP periodic reset does not fully restore gateway group round-robin functionality

Added by Daniel Pereira about 1 year ago. Updated about 1 year ago.

Status:
New
Priority:
Normal
Assignee:
Category:
Gateways
Target version:
Start date:
09/07/2020
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.4.5-p1
Affected Architecture:

Description

I'm using a Multi-WAN setup with two links working in a load-balancer fashion.

I set up a periodic reset for both my PPP connections every 24h so I get new IP addresses. One link is reset at 4:20 and the other at 4:21.

I noticed that the link that gets restarted last is never able to actually come back fully: the router doesn't seem to round-robin the outbound connections anymore, and I only get to use the speed of one link. If you go to the gateway status, both gateways will be green and the "Load balanced" gateway group will be green too. No visual signal that the one link is not being actually used.

If I manually go and reset the filter, then it all comes back to work normally.

It took me some time until I traced this down to this. I tested it using SpeedTest.net with multi-connections (the default) - and by looking at the states table (noticing that one link gets ALL outbound while the other, almost none).

Actions #1

Updated by Steve Beaver about 1 year ago

  • Assignee set to Luiz Souza
Actions #2

Updated by Viktor Gurov about 1 year ago

seems related to #10716

Actions #3

Updated by Steve Beaver about 1 year ago

  • Target version changed from 2.5.0 to CE-Next
Actions

Also available in: Atom PDF