Project

General

Profile

Bug #1089

Carp and SYNC broken after upgrade to latest snapshot

Added by Francisco Brasileiro over 9 years ago. Updated over 9 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
12/09/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

After upgrade to latest snapshot the sync was stoped.

Dec 9 17:53:20 hsfw-1 check_reload_status: syncing firewall
Dec 9 17:53:20 hsfw-1 php: : An error code was received while attempting XMLRPC sync with username admin https://10.3.0.2:443 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
Dec 9 17:53:20 hsfw-1 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin https://10.3.0.2:443 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
Dec 9 17:53:20 hsfw-1 php: : An error code was received while attempting XMLRPC sync with username admin https://10.3.0.2:443 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
Dec 9 17:53:20 hsfw-1 php: : New alert found: An error code was received while attempting XMLRPC sync with username admin https://10.3.0.2:443 - Code 3: Incorrect parameters passed to method: Signature permits 1 parameters but the request had 2
Dec 9 17:53:20 hsfw-1 php: : The other member is on older version of . Sync will not be done to prevent problems!

First i upgrade the backup box, and after upgrade the master box. After this, the carp don't work, they show INIT on status and ifconfig on both box. To solve I had to edit and save all carps, so they bring to MASTER.

On BACKUP BOX the system log show:

Dec 9 17:53:53 hsfw-2 check_reload_status: syncing firewall
Dec 9 17:53:53 hsfw-2 php: : CARP sync not being done because of missing sync ip!

Firmware Info:

2.0-BETA4 (i386)
Previous: Sat Nov 27 03:13:22 EST 2010
Upgraded to: Thu Dec 9 04:14:22 EST 2010

History

#1 Updated by Jim Pingle over 9 years ago

  • Status changed from New to Rejected

Duplicate of #1088

Also available in: Atom PDF