Project

General

Profile

Bug #1097

Onload Javascript on Rules page of management GUI

Added by dasanco dasanco over 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
12/13/2010
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

I attempted to install and run a test bed running 2.0-BETA4.
I proceeded to import existing rules from a live 1.2.3 platform.

Although the 'Rules' page displayed 'very' similarly in 2.0, the moment the page load completed the browser ignored all further input (e.g. keyboard and mouse) for an extended period of time.
That extended time varies with the number of entries on the page. The LAN tab having a couple dozen rules was inaccessible for several minutes. The WAN tab having a couple hundred rules was inaccessible for a FULL 15 MINUTES. This affected all tabs and menus in Firefox on a XP and 2K3 machine. However, it did affect ONLY the Pfsense instance (i.e. tab/window) in Opera, and the delay was about 30 seconds shorter for the WAN rules.

And of course I'm sure you already know BETA4 does not work at all in IE7. But I did attempt to load it, nonetheless.

Note: Although likely usable, I have not pursued using BETA4 at all due do this extraordinarily latency. Changing a single WAN rule would take over 45 minutes.

pfs-b4-gui-ie7.png (204 KB) pfs-b4-gui-ie7.png Screenshot dasanco dasanco, 12/13/2010 02:22 PM

History

#1 Updated by Chris Buechler over 8 years ago

  • Category set to Web Interface
  • Target version set to 2.0
  • Affected Version set to 2.0

#2 Updated by Chris Buechler over 8 years ago

You seeing this in IE?

#3 Updated by dasanco dasanco over 8 years ago

You've got me a bit worried with that question?!
I cannot get the 2.0-BETA4 GUI to even load in IE7, on any machine, even before the rules import.

I figured that to be the norm for a linux/unix based beta. The hardest compatibility issues are deferred 'til last.

However, your question seems to indicate that issue doesn't exist.

But to answer your question.
I don't know. IE7 doesn't load any menu content at all, just the graphics. So I cannot navigate to load that page. Although, I guess I could copy-n-paste the URL from the Rules page in a Firefox browser into IE7. But I figured as broken as the presentation was in IE7, it wouldn't be a very accurate test since the page would never really be loaded.

The errors to follow that shown in the screenshot are;
line 1080: Object doesn't support this property or method
line 1089: Object doesn't support this property or method
line 1497: 'CsrfMagic' is undefined

I figured something that blatant had to be a known issue?! But you know the sayin regarding 'assume'.

Shall I open a separate ticket for this?

#4 Updated by Chris Buechler over 8 years ago

I ask because I've been on several systems with a lot of rules and never seen anything like you describe, and figured you may be using IE 8, where none of us developers use IE. The IE 7 issue(s) is different and should have a separate ticket.

#5 Updated by Chris Buechler over 8 years ago

  • Priority changed from High to Normal

#6 Updated by Ermal Lu├ži over 8 years ago

Can you please confirm that this happens still on latest snapshots?

#7 Updated by dasanco dasanco over 8 years ago

I can confirm the onload javascript issue seems to be fixed when in Firefox (win32) on the following build;

2.0-BETA5 (i386)
built on Thu Feb 24 17:17:04 EST 2011

However, it does seem nothing has changed in regard to internet explorer (ie7).
None of the pages load completely and no functionality is possible.
Most pages simple display an endless display of alert errors.

As soon as I can find the time, I'll search to see if the IE issue has already been posted.
If not, I'll add it.

#8 Updated by Chris Buechler almost 8 years ago

  • Status changed from New to Closed

Also available in: Atom PDF