Project

General

Profile

Regression #11455

The ipsec configuration migrated from 2.4.x to 2.5 fails in certain cases.

Added by oscar sacristan about 2 months ago. Updated about 2 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
-
Start date:
02/18/2021
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:
Release Notes:
Default

Description

An ipsec configuration with version 2.4.x that contains these values
<rekey_time>0</rekey_time>
<reauth_time>0</reauth_time>
When upgrading to 2.5 it keeps the same values
These values fail in 2.5
The correct values apparently in 2.5 would be
<rekey_time></rekey_time>
<reauth_time></reauth_time>
0 does not seem to be allowed in 2.5.

History

#1 Updated by Jim Pingle about 2 months ago

  • Tracker changed from Bug to Regression
  • Status changed from New to Not a Bug
  • Assignee set to Jim Pingle

There is no problem with having 0 for those. It will still work properly and assume sane defaults as if they are blank.

I tested several tunnels here manually forced with both values at 0 and they worked fine.

Also available in: Atom PDF