Project

General

Profile

Actions

Bug #11480

closed

mDNS repeater (Avahi) over WireGuard not working at all

Added by Michael . 11 months ago. Updated 11 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
WireGuard
Target version:
-
Start date:
02/20/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.5.0
Affected Architecture:
All

Description

Hi,

I've been enjoying WireGuard so far with the nightly builds of pfSense 2.5 and am happy to see the full release of 2.5 today with official WG support in the kernel!

I've been experimenting a bit with WG, and have decided on a setup akin to the one described here ([[https://docs.netgate.com/pfsense/en/latest/recipes/wireguard-ra.html]]) where my pfSense box acts as a 'server' for my clients to connect to, so they may use the same network as my firewall.

I also went a bit beyond what was described in the tutorial and setup an Interface Assignment for wg0, my WG tunnel in question, with the firewall set to allow all traffic to other subnets/the web.

Now I'm looking into using the Avahi mDNS repeater which I've already setup on the firewall to repeat over the 192.168.15.1/24 subnet which I use for WG peers. Despite me selecting the wg0 Interface in the Avahi web config (in addition to other VLANs I had previously), and me adding 224.0.0.251/32 to the WG Peer "Allowed IPs" box in pfSense (my client's allowed IPs are 0.0.0.0/0), I can't seem to get it working. My clients can't pick up any mDNS devices. I've attached a photo of my pfSense WG Peer config for reference. I've also attached a snipped of my pfTop output for port 5353, looks like my WG subnet (192.168.15.1) is sending mDNS request to 224.0.0.251...
I have the "Repeat mdns packets across subnets" option in Avahi enabled too.

I was told to file a bug report here after posting on the forums first, and am happy to help with gathering more data if needed.

Cheers.


Files

img2.png (39.3 KB) img2.png Michael ., 02/20/2021 06:04 AM
img1.png (151 KB) img1.png Michael ., 02/20/2021 06:04 AM

Related issues

Is duplicate of Feature #11498: WireGuard does not pass multicast traffic to peerNewPeter Grehan02/22/2021

Actions
Actions #1

Updated by Jim Pingle 11 months ago

  • Status changed from New to Duplicate

This is due to WireGuard on FreeBSD not passing multicast or broadcast traffic. We had an issue open on our internal Redmine before the WireGuard code was public. I moved it over now. It's in #11498

Actions #2

Updated by Jim Pingle 11 months ago

  • Is duplicate of Feature #11498: WireGuard does not pass multicast traffic to peer added
Actions

Also available in: Atom PDF