Project

General

Profile

Actions

Bug #11542

closed

Openvpn does not work correctly after updating to version 2.5.0

Added by itfabrica Tech 9 months ago. Updated 9 months ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
-
Start date:
02/26/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

Good day!
After updating from version 2.4.5-RELEASE-p1 to version 2.5.0, openvpn does not work correctly.
The first connection to the server occurs without error, then, for example, if the client computer goes to sleep or the Internet is disconnected on it and then the computer wakes up from sleep mode or connects the Internet back, the VPN session will be restored, but the traffic stops going.
Only deleting the session on the openvpn server helps.


Files

openvpn1.txt (82.3 KB) openvpn1.txt itfabrica Tech, 02/25/2021 04:37 PM
Actions #1

Updated by itfabrica Tech 9 months ago

openvpn log in atach

Actions #2

Updated by Jim Pingle 9 months ago

  • Status changed from New to Rejected
  • Priority changed from High to Normal
  • Target version deleted (2.5.1)
  • Affected Version deleted (2.4.5-p1)

There isn't enough information here to suggest it's a bug in pfSense. Please post on the forum to discuss and diagnose the problem.

Actions #3

Updated by itfabrica Tech 9 months ago

and yet I insist that this is a problem
https://redmine.pfsense.org/issues/11634

Actions #4

Updated by St├ęphane BARBARAY 9 months ago

I confirm the problem, I have to wait approx 5mn before trying to reconnect
I did not see anything suspicious in log except that connection is restarted with client because no ping is coming... I have to explicitly stop reconnect client side then wait before retrying manually
Incase of : enabling or disabling autonegotiation does not circumvent this problem

Actions #5

Updated by Jim Pingle 9 months ago

It is not a bug in pfSense, it is a bug in OpenVPN. See #11575

Actions

Also available in: Atom PDF