Project

General

Profile

Bug #11619

Unable to upgrade 2.4.4-p3 to 2.5/21.02-p1

Added by Viktor Gurov 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
Upgrade
Target version:
-
Start date:
03/04/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:

Description

issue with upgrading 2.4.4-p3 to 2.5/21.02-p1:

>>> Updating repositories metadata... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pkg-static: Repository pfSense has a wrong packagesite, need to re-create database
Fetching meta.conf: . done
Fetching packagesite.txz: .......... done
Processing entries: 
pkg-static: Newer FreeBSD version for package pfSense-pkg-softflowd:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1202504
- running kernel: 1102000

pkg-static: repository pfSense contains packages for wrong OS version: FreeBSD:12:amd64
Processing entries... done
Unable to update repository pfSense
Error updating repositories!
>>> Locking package pkg... done.
ERROR: Unable to compare version of pfSense-repo

this is a clean 2.4.4-p3 install

Workaround:
update from 2.4.4-p3 to 2.4.5-p1
then from 2.4.5-p1 to 2.5/21.02-p1

History

#1 Updated by Viktor Gurov 2 months ago

  • Subject changed from Unable to upgrade 2.4.4-p3 to 2.5 to Unable to upgrade 2.4.4-p3 to 2.5/21.02-p1

#2 Updated by Viktor Gurov 2 months ago

same issue with updating 2.3.5 to 2.4.4-p3/2.4.5-p1:

>>> Updating repositories metadata... 
Updating pfSense-core repository catalogue...
pfSense-core repository is up to date.
Updating pfSense repository catalogue...
pkg-static: Repository pfSense has a wrong packagesite, need to re-create database
Fetching meta.conf: . done
Fetching packagesite.txz: .......... done
Processing entries: 
pkg-static: Newer FreeBSD version for package minicron:
To ignore this error set IGNORE_OSVERSION=yes
- package: 1103504
- running kernel: 1003000

pkg-static: repository pfSense contains packages for wrong OS version: FreeBSD:11:amd64
Processing entries... done
Unable to update repository pfSense
Error updating repositories!
>>> Locking package pkg... done.
ERROR: Unable to compare version of pfSense-repo

Also available in: Atom PDF