Project

General

Profile

Bug #11789

Restore Nat Outbound Config Issue

Added by Daniele Ciribifera about 1 month ago. Updated 23 days ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Backup / Restore
Target version:
-
Start date:
04/07/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.5.0
Affected Architecture:
amd64

Description

Hi all,
I'm reporting a bug about the Restore from config file of NAT Config.
The Outbound config is "Manual Outbound NAT" and the backup/restore was not encrypted.
The "Inbound" and "1:1" TAB import process was ok, but Outbound rules are missing, it is completly empty.
I tried to make a new rule and then save a new Backup file.
Into the XML there were both the new rule and the old rules, but every try to import than was unsuccesfull.
I noted that the old rules backuped froma 2.4 version, were missing two parameters
<source_hash_key></source_hash_key>
<ipprotocol>inet</ipprotocol>

I tried to modify some rule, cutting them (there were 90) but I didn't solve, the restore process didn't load any rule.
Neither the new One I made on the new 2.5 platform.
I think that is a bug, but let you investigate.
Thank you.
Best regards.
Daniele

History

#1 Updated by Jim Pingle 23 days ago

  • Status changed from New to Rejected

Can't reproduce as stated.

I can backup a NAT section, wipe out the rules in the GUI, then restore, and they are all back, even outbound NAT.

For assistance in solving problems, please post on the Netgate Forum or the pfSense Subreddit .

See Reporting Issues with pfSense Software for more information.

Also available in: Atom PDF