Project

General

Profile

Actions

Regression #11806

closed

IPv4 link-local (``169.254.x.x``) gateway does not function

Added by Jim Pingle 4 months ago. Updated 2 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
Routing
Target version:
Start date:
04/14/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
21.05
Release Notes:
Default
Affected Version:
2.1.5
Affected Architecture:

Description

On 2.5.1, there is a regression caused by the change in #11713 which ends up treating IPv4 link local addresses like IPv6. It incorrectly attempts to add a % scope to the address and fails, since it doesn't exist for IPv4. Due to that incorrect usage, if an IPv4 link uses a link-local address from 169.254.x.x as its gateway, the route is not added to the table.

Limiting the change from #11713 to only IPv6 addresses partially solves the problem but also results in "route has not been found" errors similar to those reported in #11713, so that change alone is not sufficient to solve the problem.

See https://forum.netgate.com/topic/162935/pfsense-2-5-1-not-recognizing-my-default-ipv4-route for additional details.

Actions #1

Updated by Viktor Gurov 3 months ago

Jim Pingle wrote:

Limiting the change from #11713 to only IPv6 addresses partially solves the problem but also results in "route has not been found" errors similar to those reported in #11713, so that change alone is not sufficient to solve the problem.

For some reason it doesn't suppress (`2>/dev/null`) "route has not been found" errors on boot:
https://github.com/pfsense/pfsense/blob/3af1961155caafb890cfb635d7278e1498ae7423/src/etc/inc/util.inc#L2682

Actions #2

Updated by Viktor Gurov 3 months ago

https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/221

"route has not been found" - another issue and not related to IPv4 Link-Local gateways (caused by `ipsec_setup_routes()`)
I can see such error with non-IPv4 Link-Local gateways too

Actions #3

Updated by Viktor Gurov 3 months ago

Viktor Gurov wrote:

Jim Pingle wrote:

Limiting the change from #11713 to only IPv6 addresses partially solves the problem but also results in "route has not been found" errors similar to those reported in #11713, so that change alone is not sufficient to solve the problem.

For some reason it doesn't suppress (`2>/dev/null`) "route has not been found" errors on boot:
https://github.com/pfsense/pfsense/blob/3af1961155caafb890cfb635d7278e1498ae7423/src/etc/inc/util.inc#L2682

Could be STDOUT/STDERR issue, like #11430

Actions #4

Updated by Jim Pingle 3 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
  • Target version changed from CE-Next to 2.6.0
Actions #5

Updated by Jim Pingle 3 months ago

  • Status changed from Pull Request Review to Feedback

PR was merged yesterday.

Actions #6

Updated by Jim Pingle 3 months ago

  • Plus Target Version set to 21.05
Actions #7

Updated by Jim Pingle 3 months ago

Already in 21.05 branch.

Actions #8

Updated by Jim Pingle 3 months ago

  • Subject changed from IPv4 link-local (169.254.x.x) gateway does not function to IPv4 link-local (``169.254.x.x``) gateway does not function

Updating subject for release notes.

Actions #9

Updated by Jim Pingle 2 months ago

  • Target version changed from 2.6.0 to 2.5.2
Actions #10

Updated by Jim Pingle 2 months ago

  • Status changed from Feedback to Closed
Actions

Also available in: Atom PDF