Project

General

Profile

Actions

Bug #11860

closed

GIF interfaces should be reconfigured when IPv6 address of a WAN-Interface changes

Added by Thorsten Zitterell 7 months ago. Updated 7 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
-
Start date:
04/27/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:
All

Description

I have successfully configured my router for DS-lite (NetCom BW, Germany) using PPPoE for initial WAN setup (IPv4 & IPv6 addresses). A GIF interface tunnels my private IPv4 addresses.

However, the tunnelled IPv4 connection stops working whenever rc.newwanip is called. It seems that the GIF-Interface is reconfigured before an IPv6 address has been retrieved.

If the GIF-interface has an IPv6 address as a remote peer then I think the GIF-tunnel should be reconfigured whenever rc.newwanipv6 is called.

I placed this code in rc.newwanipv6 (almost at the end after the OpenVPN part) which works for me as a workaround.


unset($gif);
$gif = link_interface_to_tunnelif($interface, 'gif');
if (!empty($gif)) {
array_walk($gif, 'interface_gif_configure');
}


Related issues

Is duplicate of Bug #6507: GRE and GIF tunnels on dynamic IPv6 interface are not brought up during bootFeedbackViktor Gurov06/20/2016

Actions
Actions #2

Updated by Thorsten Zitterell 7 months ago

Viktor Gurov wrote:

should be fixed by https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/63
see #6507

Thank you. It seems that #6507 and this problem are related. However, the link is broken. According to the description it refers to GRE not GIF tunnels.

Actions #3

Updated by Jim Pingle 7 months ago

  • Status changed from New to Duplicate

Thorsten Zitterell wrote:

Viktor Gurov wrote:

should be fixed by https://gitlab.netgate.com/pfSense/pfSense/-/merge_requests/63
see #6507

Thank you. It seems that #6507 and this problem are related. However, the link is broken. According to the description it refers to GRE not GIF tunnels.

The link is to our internal gitlab, and that PR does fix both GIF and GRE even though the issue itself only mentions GRE. So this issue can be closed as a duplicate.

Actions #4

Updated by Jim Pingle 7 months ago

  • Is duplicate of Bug #6507: GRE and GIF tunnels on dynamic IPv6 interface are not brought up during boot added
Actions

Also available in: Atom PDF