Project

General

Profile

Actions

Bug #12006

closed

CARP IP sometimes doesn't apply to CARP member

Added by Andrew Waranowski over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
CARP
Target version:
-
Start date:
06/07/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

I noticed this when a CARP member had no CARP status. I was told that this can happen if the VIP address isn't applied to a member.

I saw this recently on a pfSense VM, and confirmed that the member which had a blank CARP status didn't have VIP IP applied to it. In this case, it was the backup unit. I was able to fix it by editing the virtual IP address, and then clicking 'save'. Then the IP properly applied. I was told that this issue sometimes appears after a software upgrade. Indeed, that jives, because I had recently upgraded the VM.

I saw it on:
2.5.1-RELEASE


Related issues

Is duplicate of Bug #12202: When a CARP VIP VHID change is synchronized to a secondary node, the CARP VIP is removed from the interface and the old VHIDs remain activeResolved

Actions
Actions #1

Updated by Viktor Gurov over 1 year ago

seems to be related to #12202

Actions #2

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Duplicate

Reads the same to me. Closing as a duplicate. Can always reopen if we can get more detail that shows it's a unique problem.

Actions #3

Updated by Jim Pingle over 1 year ago

  • Is duplicate of Bug #12202: When a CARP VIP VHID change is synchronized to a secondary node, the CARP VIP is removed from the interface and the old VHIDs remain active added
Actions

Also available in: Atom PDF