Project

General

Profile

Actions

Bug #12033

open

maxmindb and _sqlite3 modules not found

Added by Viktor Gurov 4 months ago. Updated 24 days ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
pfBlockerNG
Target version:
-
Start date:
06/14/2021
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

https://forum.netgate.com/topic/164305/py_error-log-errors-maxmindb-and-_sqlite3-modules-not-found

I am using pfblockerNG-devel 3.0.0_16 with pfSense 21.05 on an SG-3100 and seeing errors like the ones below in py_error.log. Any explanation?

2021-06-07 00:05:39,966|ERROR| [pfBlockerNG]: Failed to load python module 'maxminddb': No module named 'maxminddb'
2021-06-07 00:05:39,967|ERROR| [pfBlockerNG]: Failed to load python module 'sqlite3': No module named '_sqlite3'

see the same issue on my SG-3100

Actions #1

Updated by Viktor Gurov 24 days ago

see the same error on SG-3100 with pfSense-21.09.r.20210923.2242 and pfBlockerNG-3.1.0:

2021-06-03 10:13:08,728|ERROR| [pfBlockerNG]: Failed to load python module 'maxminddb': No module named 'maxminddb'
2021-06-03 10:13:08,730|ERROR| [pfBlockerNG]: Failed to load python module 'sqlite3': No module named '_sqlite3'

but modules are installed:

# pkg info -l py38-sqlite3
py38-sqlite3-3.8.11_7:
    /usr/local/lib/python3.8/lib-dynload/_sqlite3.cpython-38.so
    /usr/local/lib/python3.8/lib-dynload/sqlite3-0.0.0-py3.8.egg-info/PKG-INFO
    /usr/local/lib/python3.8/lib-dynload/sqlite3-0.0.0-py3.8.egg-info/SOURCES.txt
    /usr/local/lib/python3.8/lib-dynload/sqlite3-0.0.0-py3.8.egg-info/dependency_links.txt
    /usr/local/lib/python3.8/lib-dynload/sqlite3-0.0.0-py3.8.egg-info/top_level.txt
    /usr/local/share/licenses/py38-sqlite3-3.8.11_7/LICENSE
    /usr/local/share/licenses/py38-sqlite3-3.8.11_7/PSFL
    /usr/local/share/licenses/py38-sqlite3-3.8.11_7/catalog.mk
# pkg info -l py38-maxminddb
py38-maxminddb-2.0.3:
    /usr/local/lib/python3.8/site-packages/maxminddb-2.0.3-py3.8.egg-info/PKG-INFO
    /usr/local/lib/python3.8/site-packages/maxminddb-2.0.3-py3.8.egg-info/SOURCES.txt
    /usr/local/lib/python3.8/site-packages/maxminddb-2.0.3-py3.8.egg-info/dependency_links.txt
    /usr/local/lib/python3.8/site-packages/maxminddb-2.0.3-py3.8.egg-info/top_level.txt
    /usr/local/lib/python3.8/site-packages/maxminddb/__init__.py
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/__init__.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/__init__.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/const.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/const.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/decoder.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/decoder.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/errors.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/errors.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/file.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/file.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/reader.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/reader.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/types.cpython-38.opt-1.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/__pycache__/types.cpython-38.pyc
    /usr/local/lib/python3.8/site-packages/maxminddb/const.py
    /usr/local/lib/python3.8/site-packages/maxminddb/decoder.py
    /usr/local/lib/python3.8/site-packages/maxminddb/errors.py
    /usr/local/lib/python3.8/site-packages/maxminddb/extension.cpython-38.so
    /usr/local/lib/python3.8/site-packages/maxminddb/file.py
    /usr/local/lib/python3.8/site-packages/maxminddb/py.typed
    /usr/local/lib/python3.8/site-packages/maxminddb/reader.py
    /usr/local/lib/python3.8/site-packages/maxminddb/types.py
    /usr/local/share/licenses/py38-maxminddb-2.0.3/APACHE20
    /usr/local/share/licenses/py38-maxminddb-2.0.3/LICENSE
    /usr/local/share/licenses/py38-maxminddb-2.0.3/catalog.mk

Actions #2

Updated by Viktor Gurov 24 days ago

How to resolve:

# rm /var/log/pfblockerng/py_error.log

and Force Update/Reload

https://forum.netgate.com/topic/164934/errors-after-upgrade-to-2-5-2

Actions

Also available in: Atom PDF