Project

General

Profile

Actions

Regression #12288

closed

GRE and GIF tunnel inside addresses are missing at the OS level after applying changes on assigned interfaces

Added by Jim Pingle 9 months ago. Updated 4 months ago.

Status:
Closed
Priority:
High
Assignee:
Category:
Interfaces
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
2.6.0
Affected Architecture:

Description

Starting from scratch if you create a new GRE interface and assign+enable it, the inner address on the tunnel interface is missing. Even re-saving the GRE interface does not bring it back.

After a reboot, the expected addresses are present.

Doesn't appear to affect the current release, only snapshots, so possibly from a recent change.


Related issues

Related to Bug #6507: GRE and GIF tunnels on dynamic IPv6 interface are not brought up during bootClosedViktor Gurov06/20/2016

Actions
Actions #1

Updated by Jim Pingle 9 months ago

Also worth noting that the addresses are present when the GRE is first created, and only disappear after assigning/enabling and applying changes:

  • Create GRE: Inside addresses are present.
  • Assign interface: Inside addresses are present.
  • Check enable, change name, save: Inside addresses are present.
  • Apply Changes: Inside addresses are missing.
Actions #2

Updated by Jim Pingle 9 months ago

Target can be moved ahead if pressed for time. Nice to fix, but there is a viable workaround so not critical.

Actions #3

Updated by Jim Pingle 8 months ago

  • Plus Target Version changed from 21.09 to 22.01

Move to next Plus release.

Actions #4

Updated by Jim Pingle 7 months ago

  • Subject changed from GRE tunnel inside addresses are missing after assignment to GRE and GIF tunnel inside addresses missing after applying changes on assigned interface

This also applies to GIF interfaces. Additionally, it doesn't happen on assignment but any time changes are applied.

Actions #5

Updated by Viktor Gurov 7 months ago

  • Related to Bug #6507: GRE and GIF tunnels on dynamic IPv6 interface are not brought up during boot added
Actions #7

Updated by Jim Pingle 7 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
Actions #8

Updated by Viktor Gurov 7 months ago

  • Status changed from Pull Request Review to Feedback

Merged

Actions #9

Updated by Jim Pingle 7 months ago

  • Subject changed from GRE and GIF tunnel inside addresses missing after applying changes on assigned interface to GRE and GIF tunnel inside addresses are missing at the OS level after applying changes on assigned interfaces

Updating subject for release notes.

Actions #10

Updated by Viktor Gurov 4 months ago

  • Release Notes changed from Default to Force Exclusion

This is 2.6 only regression fix, related to #6507 changes

Actions #11

Updated by Jim Pingle 4 months ago

  • Status changed from Feedback to Closed

This has been working well since the fix went in. I've saved/applied on asigned GIF interfaces numerous times and the interfaces are working afterward.

Actions

Also available in: Atom PDF