Project

General

Profile

Actions

Bug #12497

closed

OpenVPN Server assignes random IPv4 addresses to active clients even if FreeRadius has configured Framed-IP for all these remote clients

Added by Azamat Khakimyanov 3 months ago. Updated 19 days ago.

Status:
Duplicate
Priority:
Normal
Assignee:
Category:
OpenVPN
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.6.0
Affected Architecture:

Description

For Remote Access OpenVPN Server all connected clients still gets IP-addresses from OpenVPN pool instead of getting configured Framed-IPs from FreeRadius.

I run Packet Capture and caught traffic between pfSense and FreeRadius (pcap_with_radius.png) and I saw that FreeRadius sent correct Framed-IP (vpnuser_IPv4_and_IPv6_attributes.png) in its response but still OpenVPN client got random IP-address (ifconfig_Ubuntu.png) from OpenVPN pool.

Viktor found this link: https://serverfault.com/questions/796872/openvpn-radius-plugin-does-not-assign-framed-ip-address-from-freeradius-to-clien
and adding 'client-config-dir clients' option into 'Additional configuration options' (OpenVPN/Client Export Utility) helped to fix it and after redownloading new ovpn file I saw correct (Framed-IP) on remote client with active OpenVPN tunnel.

But only Framed-IPv4 attributes work. Framed-IPv6 attributes don't work: https://redmine.pfsense.org/issues/12496


Files

pcap_with_radius.png (98 KB) pcap_with_radius.png Azamat Khakimyanov, 11/01/2021 06:37 AM
ifconfig_Ubuntu.png (17.9 KB) ifconfig_Ubuntu.png Azamat Khakimyanov, 11/01/2021 06:37 AM
vpnuser_IPv4_and_IPv6_attributes.png (94.5 KB) vpnuser_IPv4_and_IPv6_attributes.png Azamat Khakimyanov, 11/01/2021 06:38 AM

Related issues

Is duplicate of Bug #12076: OpenVPN RADIUS-based firewall rules do not use expected value for RADIUS-assigned IP addressesResolvedViktor Gurov06/23/2021

Actions
Actions #1

Updated by Viktor Gurov 19 days ago

  • Status changed from New to Duplicate

Duplicate of #12076

Actions #2

Updated by Viktor Gurov 19 days ago

  • Project changed from pfSense Plus to pfSense
  • Category changed from OpenVPN to OpenVPN
  • Affected Version set to 2.6.0
Actions #3

Updated by Viktor Gurov 19 days ago

  • Is duplicate of Bug #12076: OpenVPN RADIUS-based firewall rules do not use expected value for RADIUS-assigned IP addresses added
Actions

Also available in: Atom PDF