Project

General

Profile

Actions

Regression #12550

closed

PHP ``foreach`` error in IPsec status

Added by Jim Pingle about 2 months ago. Updated 7 days ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
IPsec
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
22.01
Release Notes:
Force Exclusion
Affected Version:
2.6.0
Affected Architecture:

Description

In rare occasions I have hit a PHP error from the IPsec status page, though I haven't managed to replicate it on demand yet.

[30-Nov-2021 12:59:47 America/New_York] PHP Warning:  Invalid argument supplied for foreach() in /usr/local/www/status_ipsec.php on line 117

Probably easy to fix with an isset + is_array check before the foreach.

Actions #2

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Pull Request Review
  • Assignee set to Viktor Gurov
Actions #3

Updated by Viktor Gurov about 2 months ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle about 2 months ago

  • Release Notes changed from Default to Force Exclusion

This was a bug with new code added after the last release, so no need for it to be in the release notes.

Actions #5

Updated by Jim Pingle 7 days ago

  • Status changed from Feedback to Resolved

No sign of this since the fix went in.

Actions

Also available in: Atom PDF