Project

General

Profile

Actions

Bug #12811

closed

Services are not restarted when PPP interfaces connect

Added by Oskar Stroka over 2 years ago. Updated over 1 year ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
PPP Interfaces
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Default
Affected Version:
2.6.0
Affected Architecture:
amd64

Description

Hi there, I've got a Gateway Group containing my WAN (VDSL with PPPoE) on Tier 1 and my 2nd WAN (LTE Modem) on Tier 2.
The Failover from Tier 1 to Tier 2 works flawlessly, but the "recovery" or failback to Tier 1 seems to be flawed.

If Tier 1 (VDSL with PPPoE) fails, all traffic (Wireguard in that case) will almost immediately be routed through Tier 2 (LTE Modem).
If Tier 1 comes back up, Status - Gateways - Gateway Groups even shows that change, the traffic will still flow through Tier 2.
By the way: This Gateway Group is set as my default gateway.

Diagnosis:
I've put 2 additional lines in /etc/rc.gateway_alarm.

echo "$GW" >> /tmp/test
echo "$alarm_flag" >> /tmp/test

Here is the output if Tier 1 fails:
WAN_PPPOE
1

but there's no output if Tier 1 comes back up.

I GUESS rc.gateway_alarm doesn't get triggered, and I GUESS this only happens if the IP on the PPPoE interface didn't change.

The only way for me to force traffic back through Tier 1 is to disable or unplug the interface on Tier 2.

This only happens on the PPPoE Interface, the other Interfaces act as expected.


Related issues

Related to Regression #11570: Gateway monitoring services is not always restarted on interface events, which may prevent a WAN from recovering back to an online stateClosed

Actions
Actions #1

Updated by Viktor Gurov over 2 years ago

Related to #11570
similar issue with OpenVPN - #12771

Actions #2

Updated by Viktor Gurov over 2 years ago

  • Related to Regression #11570: Gateway monitoring services is not always restarted on interface events, which may prevent a WAN from recovering back to an online state added
Actions #3

Updated by Viktor Gurov over 2 years ago

  • Assignee set to Viktor Gurov
Actions #4

Updated by Jim Pingle over 2 years ago

  • Status changed from New to Pull Request Review
  • Target version set to 2.7.0
  • Plus Target Version set to 22.05
Actions #5

Updated by Viktor Gurov about 2 years ago

  • Status changed from Pull Request Review to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Oskar Stroka about 2 years ago

Thanks a lot guys :)
Is there an easy way for me to implement this change?

Actions #7

Updated by Viktor Gurov about 2 years ago

  • Priority changed from High to Normal

Oskar Stroka wrote in #note-6:

Thanks a lot guys :)
Is there an easy way for me to implement this change?

You need to install the System Patches pkg:
https://docs.netgate.com/pfsense/en/latest/development/system-patches.html

and apply patch id ec73bb89489d830ec21c4e04ffa3ec401791b55d
and c467ca2f35c102aae897424a2fda08e9b2ace673

Actions #8

Updated by Oskar Stroka about 2 years ago

Sadly, after applying those patches, the problem still persists.
Is there any way I could help you to narrow it down?

Actions #9

Updated by Jim Pingle about 2 years ago

  • Subject changed from Gateway Groups, Failover and PPPoE to Services are not restarted when PPP interfaces connect

Updating subject for release notes.

Actions #10

Updated by Jim Pingle almost 2 years ago

  • Status changed from Feedback to New
  • Assignee changed from Viktor Gurov to Jim Pingle
  • Plus Target Version changed from 22.05 to 22.09
Actions #11

Updated by Jim Pingle almost 2 years ago

  • Plus Target Version changed from 22.09 to 22.11
Actions #12

Updated by Oskar Stroka almost 2 years ago

ec73bb89489d830ec21c4e04ffa3ec401791b55d and c467ca2f35c102aae897424a2fda08e9b2ace673 actually solve the issue that the PPPoE Interface won't become the default gateway, again, after getting a new IP.
Thanks for that =)
What's missing is a way to restart the wireguard services automatically afterwards.

Actions #13

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 22.11 to 23.01
Actions #14

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
  • Start date deleted (02/16/2022)

There have been a lot of changes here since the last comment and it's not clear if this should be marked resolved or not.

From the comments it looks like the base system may be OK now but just that one package might not be working right? Would help to test this again and confirm if the problem still happens on a current snapshot.

Actions #15

Updated by Jim Pingle over 1 year ago

  • Category changed from Gateway Monitoring to Interfaces
Actions #16

Updated by Jim Pingle over 1 year ago

  • Category changed from Interfaces to PPP Interfaces
Actions #17

Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Ran some tests just now and services are restarted when the interface (re)connects (gets its address) and the rules recover when the gateway comes back up. As far as I can tell it's doing everything correctly here now.

Actions

Also available in: Atom PDF