Project

General

Profile

Actions

Regression #13248

open

IPv6 Router Advertisements runs when config.xml does not contain an entry for the interface

Added by Marcos M 2 months ago. Updated 2 months ago.

Status:
New
Priority:
Normal
Assignee:
-
Category:
DHCP (IPv6)
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
Affected Architecture:

Description

After installing 22.05.b.20220531.0600, I noticed that the System / Routing logs showed the following:

  • 2001:db8:4407:41c:20c:29ff:feae:75dc is the lan (ixv5) IPv6 address assigned from the tracked interface.
  • fe80::20c:29ff:feae:75dc is the lan (ixv5) Link-Local address.
  • lan (ixv5) shows DHCPv6 Server and RA disabled in the GUI. The interface has Tracked Interface set.
  • ixv0/2/3/4/6 have DHCPv6 Server and RA enabled. The interface has IPv6 static addresses.
Jun 5 13:03:26     radvd     51368     RDNSS address 2001:db8:4407:41c:20c:29ff:feae:75dc received on ixv0 from fe80::20c:29ff:feae:75dc is not advertised by us
Jun 5 13:03:26     radvd     51368     RDNSS address 2001:db8:4407:41c:20c:29ff:feae:75dc received on ixv4 from fe80::20c:29ff:feae:75dc is not advertised by us
Jun 5 13:03:26     radvd     51368     RDNSS address 2001:db8:4407:41c:20c:29ff:feae:75dc received on ixv2 from fe80::20c:29ff:feae:75dc is not advertised by us
Jun 5 13:03:26     radvd     51368     RDNSS address 2001:db8:4407:41c:20c:29ff:feae:75dc received on ixv3 from fe80::20c:29ff:feae:75dc is not advertised by us
Jun 5 13:03:26     radvd     51368     RDNSS address 2001:db8:4407:41c:20c:29ff:feae:75dc received on ixv6 from fe80::20c:29ff:feae:75dc is not advertised by us 

I also noticed that some hosts behind the firewall were getting two additional IPv6 addresses assigned from lan (ixv5), on top of the correct IPv6 address leased by the DHCPv6 Server. I rebooted the firewall and the issue persisted. I then re-saved the DHCPv6 Server and Router Advertisements config for ixv5, and the issue was resolved.

I ran a diff on the config.xml file before and after the issue was resolved, and noticed that the difference was that the file contained an entry under dhcpdv6 for lan (ixv5) with <ramode>disabled</ramode> included. When I was experiencing the issue, the file did not contain any entry for lan under dhcpdv6.

Actions #1

Updated by Marcos M 2 months ago

  • Description updated (diff)
Actions #2

Updated by Marcos M 2 months ago

  • Description updated (diff)
Actions #3

Updated by Marcos M 2 months ago

  • Description updated (diff)
Actions #4

Updated by Marcos M 2 months ago

  • Description updated (diff)
Actions

Also available in: Atom PDF