Project

General

Profile

Actions

Bug #13253

closed

``dhcp6c`` is not restarted when applying settings when multiple WANs are configured for DHCP6

Added by Jim Pingle almost 2 years ago. Updated 10 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP (IPv6)
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.01
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

After #6880 it seems that when applying settings on multiple WANs, dhcp6c is not restarted so the new configuration isn't picked up.

If I manually kill dhcp6c before applying changes, then it's started properly and the additional WAN picks up its IPv6 address as it should.

Rebooting also works, naturally.


Related issues

Related to Bug #6880: Multiple DHCP6 WAN connections leads to multiple dhcp6c clientsResolvedViktor Gurov10/28/2016

Actions
Actions #1

Updated by Jim Pingle almost 2 years ago

  • Related to Bug #6880: Multiple DHCP6 WAN connections leads to multiple dhcp6c clients added
Actions #2

Updated by Jim Pingle almost 2 years ago

  • Plus Target Version changed from 22.09 to 22.11
Actions #3

Updated by Jim Pingle over 1 year ago

  • Plus Target Version changed from 22.11 to 23.01
Actions #4

Updated by Jim Pingle over 1 year ago

  • Assignee set to Jim Pingle
Actions #5

Updated by Jim Pingle over 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Jim Pingle over 1 year ago

The change is working as expected for this case in the latest snapshot. Saving and applying on a DHCP6 WAN causes the client to restart.

I'll leave this open a little longer in case the change had an unintended negative impact on other DHCP6 events.

If it's still open with no negative feedback in ~1 week it can be closed.

Actions #7

Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved
Actions #8

Updated by Jim Pingle over 1 year ago

  • Status changed from Resolved to In Progress

There is a bit of a regression here in certain cases. For whatever reason the change made here is causing a failure for dhcp6/track6 on the 1100 at least, and possibly others depending on interface event timing. Also in that case it isn't starting the client if it's stopped already. So maybe it only worked by accident.

I'll investigate an alternate fix.

Actions #9

Updated by Jim Pingle over 1 year ago

  • Status changed from In Progress to Feedback
Actions #10

Updated by Jim Pingle over 1 year ago

Backing out this change and re-testing on lab systems with multiple DHCP6 WANs, dhcp6 is still restarted now. Some other change in a related area must have altered this behavior.

I'm going to re-target this and keep an eye on it. It might be that it can be closed safely now, but I'll wait until the previous commit is reverted in a snapshot to test more thoroughly.

Actions #11

Updated by Jim Pingle over 1 year ago

  • Status changed from Feedback to Resolved

Re-tested on 23.01.b.20221221.1946 and dhcp6c is restarted there when applying WAN changes.

Actions #12

Updated by Jim Pingle 10 months ago

  • Affected Version set to 2.7.0
Actions

Also available in: Atom PDF