Project

General

Profile

Actions

Bug #13328

closed

Wireguard Site-to-Site broken after upgrade to 22.05

Added by Sebastian Schmid about 1 month ago. Updated about 1 month ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
WireGuard
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
Affected Plus Version:
22.05
Affected Architecture:

Description

Hi,

I upgraded from 22.01 to 22.05. Everything went fine.
Plus home license on virtualized system
On Upgrade the new version of the WireGuard package was installed (automatically).

My 3 site-to-site connections all up.
I am using the site to site config without NATing the traffic. Install originating from 2.5.2. Since then running stable.

One day later I rebooted my pfsense.
After the reboot the VPN gateways stayed hidden and the WireGuard service was stopped (red x). Not starting on click. To troubleshoot I reinstalled the package. Everything fine, up and running.
Another reboot to test. Same thing, tunnels offline. Checked in WireGuard Status menu. Handshake to the peers green. Went to Routing and activated the gateways manually. All up and online. A few seconds later the WireGuard service starts (on it’s own) and turns green.

To troubleshoot I reinstalled today:

Reinstalled CE 2.6.0 from scratch.
Backup upload. All tunnels up, no problems at all.
Upgrade to 22.01 in the package manager
After the reboot all tunnels up.
Another reboot just to make sure, all up
Update to 22.05
All tunnels up, wireguard service red X
reinstall wireguard package, all green
reboot
wireguard service red X, all gateways hidden, in the wireguard status Handshake green.

back to snapshot 2.6.0
installed 2.7.0 devel
exact same behavior as on 22.05

pfSense-pkg-WireGuard 0.1.6_2 pfSense package WireGuard (EXPERIMENTAL)
wireguard-kmod 0.0.20220615 WireGuard implementation for the FreeBSD kernel
wireguard-tools-lite 1.0.20210914_1 Fast, modern and secure VPN Tunnel (lite flavor)

Actions #1

Updated by Sebastian Schmid about 1 month ago

After reading through here, I think this might be related to this
https://redmine.pfsense.org/issues/12808

I never had that problem on 22.01. or 2.6.0
Appeared first time in 22.05

Actions #2

Updated by Jim Pingle about 1 month ago

  • Project changed from pfSense Plus to pfSense Packages
  • Category changed from Gateways to WireGuard
  • Status changed from New to Not a Bug
  • Release Notes deleted (Default)

This is unlikely to be a bug, but something in your configuration or environment. It's working for many others in similar scenarios.

For assistance in solving problems, please post on the Netgate Forum or the pfSense Subreddit .

See Reporting Issues with pfSense Software for more information.

Actions

Also available in: Atom PDF