Project

General

Profile

Actions

Bug #13399

closed

Routing/Gateway - Can't switch from dynamic to Static IP-adress

Added by Jonas R 2 months ago. Updated about 2 months ago.

Status:
Not a Bug
Priority:
Normal
Assignee:
-
Category:
Routing
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Release Notes:
Default
Affected Plus Version:
Affected Architecture:

Description

Was doing some experiments which lead to some unforseen troubleshooting (thanks ZFS-snapshots for making it easy to revert). Whilst troubleshooting, I tried removing the Gateway IP. Which turned it into "dynamic". However, I was not able to assign it back to a static IP again.


Files

Actions #1

Updated by Jim Pingle about 2 months ago

  • Status changed from New to Not a Bug
  • Affected Plus Version deleted (22.05)

Dynamic gateways can't change that way and are not intended to. They are not true full gateway entries, they are automatic.

You should delete the gateway to clear out any custom settings on it, it will go away automatically when the interface changes to static, then you can create a new gateway with the same name it had before (or a different one).

Actions #2

Updated by Jonas R about 2 months ago

Jim Pingle wrote in #note-1:

Dynamic gateways can't change that way and are not intended to. They are not true full gateway entries, they are automatic.

You should delete the gateway to clear out any custom settings on it, it will go away automatically when the interface changes to static, then you can create a new gateway with the same name it had before (or a different one).

I would then in my very humble oppinion, like to propose that it shouldn't be possible to remove a static IP then in the first place.

Actions

Also available in: Atom PDF