Project

General

Profile

Actions

Bug #13528

closed

pfSense sends wrong NAS-IP-Address to RADIUS server

Added by Michael Mercier 2 months ago. Updated 2 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
Category:
Authentication
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Default
Affected Version:
2.6.x
Affected Architecture:

Description

22.05-RELEASE (amd64)
built on Wed Jun 22 18:56:13 UTC 2022
FreeBSD 12.3-STABLE

OpenVPN is setup to auth against RADIUS, I have 10.254.2.6 set as the 'RADIUS NAS IP Attribute', but the pfSense host is sending the WAN public IP address instead (see configuration page below)

output from freeradius -X

(0) NAS-IP-Address = xxx.xxx.57.238


Files

clipboard-202209291350-qgvh2.png (63.4 KB) clipboard-202209291350-qgvh2.png Michael Mercier, 09/29/2022 12:50 PM

Related issues

Is duplicate of Bug #13356: RADIUS NAS IP Attribute no longer sent due to attribute read from wrong config in auth.incResolvedMarcos M

Actions
Actions #1

Updated by Michael Mercier 2 months ago

Just in case it matters, the hardware is a Netgate 6100.

Actions #2

Updated by Marcos M 2 months ago

  • Is duplicate of Bug #13356: RADIUS NAS IP Attribute no longer sent due to attribute read from wrong config in auth.inc added
Actions #3

Updated by Marcos M 2 months ago

  • Status changed from New to Duplicate
Actions

Also available in: Atom PDF