Project

General

Profile

Bug #1408

DHCP DNS servers still get routes even if allow override is unchecked

Added by Jim Pingle about 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
04/02/2011
Due date:
% Done:

100%

Estimated time:
Affected Version:
2.0
Affected Architecture:
All

Description

If you have hardcoded DNS servers and uncheck "Allow DNS server list to be overridden by DHCP/PPP on WAN", DNS servers assigned by the DHCP server on a WAN are still given routes even if they are not added as system DNS servers.

Easy to reproduce by adding some DNS servers, unchecking the option, and then watching the routing table. The DNS server(s) assigned by the DHCP WAN show up in the routing table with a MAC (not an IP) as the gateway.

Associated revisions

Revision cfe92577 (diff)
Added by Ermal Luçi about 8 years ago

Ticket #1408. Do not add static routes for automatically learned dns servers from dhcp if Allow override is not selected.

Revision a73a9886 (diff)
Added by Ermal Luçi about 8 years ago

Ticket #1408. Honor the allow override settings even for ppp devices.

Revision 978cf4fd (diff)
Added by Ermal Luçi about 8 years ago

Actaully put the route adding under the conditional logic checking. Ticket #1408.

History

#1 Updated by Ermal Luçi about 8 years ago

This is caused by the dhclient script.
I do not think this should be fixed for 2.0 as this has been the behavior until now.
What is the issue it causes?

#2 Updated by Jim Pingle about 8 years ago

Seems like a pretty bad bug if you checked the option to ignore the DNS servers and yet they get static routes. I'd prefer to see a fix in 2.0, I don't think anyone would expect or have been relying on this misbehavior.

The problem I had with it is that I wanted to route 8.8.4.4 over my DSL, and had set the GUI to do just that. However, my Cable provider started handing out 8.8.4.4 as a DNS server over DHCP, so dhclient added a route to 8.8.4.4 over Cable, even though the GUI was set to route that over DSL. This led to an inconsistency in the GUI such that I chose to do two specific things (route this IP one way, and disallow override) neither of which really happened as expected.

I worked around it by flipping the WANs I had assigned for each of those servers, but if my cable provider starts handing out 8.8.8.8 as a DNS server too then I'll be stuck again and have to pick another DNS server, since dhclient isn't honoring the "do not override" setting.

#3 Updated by Ermal Luçi about 8 years ago

  • Status changed from New to Feedback

Committed a fix.

#4 Updated by Ermal Luçi almost 8 years ago

  • Status changed from Feedback to Resolved
  • % Done changed from 0 to 100

Also available in: Atom PDF