Project

General

Profile

Actions

Bug #14182

closed

PHP error when XMLRPC client attempts to synchronize without any synchronization settings in the configuration

Added by aleksei prokofiev about 1 year ago. Updated 12 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
XMLRPC
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.05
Release Notes:
Default
Affected Version:
2.7.0
Affected Architecture:

Description

After upgrading to 23.01 the FreeRADIUS XMLRPC Sync get PHP error.

PHP ERROR: Type: 1, File: /etc/inc/xmlrpc_client.inc, Line: 47, Message: Uncaught TypeError: Cannot access offset of type string on string in /etc/inc/xmlrpc_client.inc:47
Stack trace:
#0 /usr/local/pkg/freeradius.inc(2505): pfsense_xmlrpc_client->__construct()
#1 /usr/local/pkg/freeradius.inc(2453): freeradius_do_xmlrpc_sync('1.2.3.4', 'admin', '*******', '443', 'https', '150')
#2 /usr/local/pkg/freeradius.inc(794): freeradius_sync_on_changes()
#3 /etc/inc/pkg-utils.inc(715) : eval()'d code(2): freeradius_users_resync()
#4 /etc/inc/pkg-utils.inc(715): eval()
#5 /etc/rc.start_packages(66): sync_package('freeradius3')


Files

PHP_errors.log (1004 Bytes) PHP_errors.log Georgiy Tyutyunnik, 04/21/2023 12:48 PM
Actions #1

Updated by Jim Pingle about 1 year ago

  • Project changed from pfSense Plus to pfSense
  • Subject changed from FreeRADIUS XMLRPC, PHP ERROR: Type: 1, File: /etc/inc/xmlrpc_client.inc, Line: 47, to PHP error when XMLRPC client attempts to sync without any HA sync settings in the configuration
  • Category changed from XMLRPC to XMLRPC
  • Target version set to 2.7.0
  • Affected Plus Version deleted (23.01)
  • Plus Target Version set to 23.05

The only way I can see that error happening is if the HA sync settings in the configuration are empty, which isn't valid.

Though FreeRADIUS should be checking for that before attempting a sync, we should also avoid attempting to sync with empty settings in general.

Actions #2

Updated by Jim Pingle about 1 year ago

  • Assignee set to Jim Pingle
Actions #3

Updated by Jim Pingle about 1 year ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Jim Pingle about 1 year ago

  • Subject changed from PHP error when XMLRPC client attempts to sync without any HA sync settings in the configuration to PHP error when XMLRPC client attempts to synchronize without any synchronization settings in the configuration

Updating subject for release notes.

Actions #5

Updated by Georgiy Tyutyunnik about 1 year ago

tested on:
Version 23.01-RELEASE (amd64)
built on Fri Feb 10 20:06:33 UTC 2023
FreeBSD 14.0-CURRENT

unable to reproduce the original issue.
I managed to have crashes if I try and sync FREERADIUS to the pfSense without this package installed, but that is expected behavior. syncing node doesn't have any System HA Sync configured, but patch 7fb2954dce0c7732a34681d31723f4f5fe58f7c5 does not prevent these sync attempts from FREERADIUS. attaching crash dumps, just in case

Actions #6

Updated by Jim Pingle about 1 year ago

  • Status changed from Feedback to Closed

Those new errors wouldn't be related. Should we want to address those, they'd need to be in a separate issue for that package.

Actions #7

Updated by Jim Pingle 12 months ago

  • Affected Version set to 2.7.0
Actions

Also available in: Atom PDF