Project

General

Profile

Actions

Regression #14636

closed

"Legacy" strength PKCS#12 Export needs ``-legacy`` provider parameter on OpenSSL command

Added by Jim Pingle 9 months ago. Updated 6 months ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
OpenVPN Client Export
Target version:
Start date:
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
23.09
Affected Version:
Affected Plus Version:
Affected Architecture:

Description

See #14635 for details.

The export package will need a change similar to that one from #14635 but it will need to be wrapped in a version test of some kind since that parameter will not work on OpenSSL 1.1.x.

The version test will either need to check the OpenSSL version (3.x vs <3.x) or pfSense version (23.09/2.8.0 vs older) and only add the -legacy parameter to the export command when running with OpenSSL 3.0 on Plus 23.09/CE 2.8.0

Actions #1

Updated by Jim Pingle 8 months ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

I pushed this change on Wednesday:

https://github.com/pfsense/FreeBSD-ports/commit/f61ca6b81bab553e94046b1e6c5811a5f0e854e9

It's in package version 1.9_1

Actions #2

Updated by Jim Pingle 7 months ago

  • Status changed from Feedback to Resolved

Works as expected on current dev snapshots with the most recent export package.

Actions #3

Updated by Jim Pingle 6 months ago

  • Target version changed from 2.8.0 to 2.7.1
Actions

Also available in: Atom PDF