Project

General

Profile

Bug #1488

"There are no packages currently installed." is a lie

Added by Malte Stretz about 8 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
-
Target version:
Start date:
05/03/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

I upgraded from 1.2.3 nanobsd to 2.0-rc1 (currently a snapshot built on Mon May 2 21:11:55 EDT 2011).

The package manager told me I had only the Packet Capture Fix package installed. I removed that one since it was for 1.2.3 (should have been removed on upgrade I guess). Afterwards, the listw as empty and the package manager told me "There are no packages currently installed."

But I do still have a bunch of packages installed, of which at leas OpenVPN and OpenNTP still work. I'll attach a stripped down version of my config.xml.

config-stripped.xml (8.27 KB) config-stripped.xml Malte Stretz, 05/03/2011 07:28 AM

Associated revisions

Revision 348b53dd (diff)
Added by Scott Ullrich over 11 years ago

Do not allow dhcp-relay to be enabled if dhcp server is enabled on any interface.

Ticket #1488

Revision f6db0eef (diff)
Added by Chris Buechler over 11 years ago

Do not allow DHCP server to be enabled when DHCP relay is enabled, and vice versa

Ticket #1488

History

#1 Updated by Jim Pingle about 8 years ago

  • Status changed from New to Closed

OpenVPN is not a package on 2.0, it's part of the base system. OpenNTPd is also part of the base system, even if it is still configured like a package, it doesn't show up in the list because it's built in.

#2 Updated by Malte Stretz about 8 years ago

But anyterm and darkstat are still packages, right? I still have their entries in the menu (though they are broken due/throwing PHP errors). And I've got two OpenVPN entries in the Status menu. Also two times the IGMP Proxy in the Services menu. So it looks like the packages are still at least halfways installed.

Also, the entries are still in the XML file I attached.

Please reopen this bug (I can't find a button to do so).

#3 Updated by Jim Pingle about 8 years ago

That is because a package failed to reinstall, which is not related to this. If a package fails during the reinstall process, it doesn't complete all of the actions for the remaining packages, and they just appear to be gone and their remains are left in the config. Not quite the same problem here. The package failing to reinstall is the real problem that needs to be fixed.

#4 Updated by Malte Stretz about 8 years ago

Looks like all packages failed to reinstall for some reason, so I guess the problem isn't/wasn't in the packages but somewhere in pfSense (maybe fixed already since I first upgraded some time ago). But shouldn't pfSense handle broken packages more graceful and at least allow me to purge broken packages?

Also available in: Atom PDF