Project

General

Profile

Actions

Bug #160

closed

Captive portal interfaces box doesn't expand

Added by Chris Buechler about 12 years ago. Updated about 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Captive Portal
Target version:
Start date:
11/17/2009
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0
Affected Architecture:

Description

On a system with > 3 interfaces, the Interface box on services_captiveportal.php needs to expand so all the interfaces are visible. As is, it's difficult to select interfaces where you have > 3 on the box. Screenshot attached


Files

Voila_Capture33.voila.zip (25.2 KB) Voila_Capture33.voila.zip Chris Buechler, 11/17/2009 10:02 PM
Actions #1

Updated by Ermal Luçi about 12 years ago

The only option is to make a multi column combo box.
I am not sure this is possible in a web based GUI though i see it as the only option otherwise the GUI would get messy with to many entries.

Actions #2

Updated by Chris Buechler about 12 years ago

Could it not just be made as long as the interface list? Generally that isn't going to be more than maybe 10-20 entries tops, though it could be much longer. Even a maximum length of something like 20 entries, and the ability to scroll easily (the way it's setup now it doesn't have a scroll bar in some browsers, you have to use the arrow keys to navigate) would be much easier to work with. Though even at 100+ interfaces I don't think it would be a problem to expand that box to the full length needed to display the interfaces. Not pretty, but functionally fine.

Actions #3

Updated by Scott Ullrich about 12 years ago

  • Status changed from New to Resolved
  • % Done changed from 0 to 100
Actions #4

Updated by Chris Buechler about 12 years ago

  • Status changed from Resolved to New
  • % Done changed from 100 to 0

No change (size is still 3 when you have 5 interfaces)

Actions #5

Updated by Scott Ullrich about 12 years ago

  • Status changed from New to Feedback

Maybe your gitsync is not working.

It works fine, here is a screenshot of a box sized 4.

http://yfrog.com/1d3atp

Actions #6

Updated by Chris Buechler about 12 years ago

  • Status changed from Feedback to Resolved

yeah this is ok now, not sure what happened to my sync earlier.

Actions

Also available in: Atom PDF