Project

General

Profile

Bug #1612

Custom scripts in /usr/local/etc/rc.d get deleted

Added by Chris Buechler almost 8 years ago. Updated almost 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
Package System
Target version:
Start date:
06/22/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
2.0
Affected Architecture:

Description

The package reinstall process (it appears) deletes unknown startup scripts in /usr/local/etc/rc.d/ which is commonly used by users with customized systems for startup scripts. Anything not associated with an installed package gets deleted.

Associated revisions

Revision a8e5fc7f (diff)
Added by Chris Buechler over 11 years ago

Trim long interface names to prevent broken rulesets.

Ticket #1612

Revision 62d3ad83 (diff)
Added by Chris Buechler over 11 years ago

Prevent users from entering queue names that break the ruleset

sort of related to Ticket #1612

History

#1 Updated by Ermal Luçi almost 8 years ago

You are sure to be on latest version.
I recall this happened during package improvements and i fixed this regression by then.

#2 Updated by Chris Buechler almost 8 years ago

Yeah I thought it was, but it happens on the newest snapshot.

#3 Updated by Ermal Luçi almost 8 years ago

I investigated this and i cannot see in any place in pfSense base code something like that being done apart
the sections mentioned here.

07:52 < eri--> hmm i do not see anywhere a rm or unlink being done on /usr/local/etc/rc.d
07:54 < eri--> ../../etc/phpshellsessions/removepkgconfig:7:echo "Removing startup files from /usr/local/etc/rc.d/...\n";
07:54 < eri--> ../../etc/phpshellsessions/removepkgconfig:8:exec("rm /usr/local/etc/rc.d/*");
07:54 < eri--> this is a phpshellsession
07:57 < eri--> and the new installer upgrade function seems to do the offending line
07:57 < eri--> ../../usr/sbin/pc-sysinstall/backend/functions-upgrade.sh:76:  rm -rf ${FSMNT}/etc/rc.d >/dev/null 2>/dev/null

Possibly the system log can help here since i cannot reproduce here.

#4 Updated by Chris Buechler almost 8 years ago

  • Status changed from New to Closed

nevermind, I apparently can't see straight this morning, the file is still there... it shifted positions in ls because I first tried in the middle of a package reinstall.

#5 Updated by Evgeny Yurchenko almost 8 years ago

Tried to reproduce:
  1. echo test >/etc/rc.d/test
  2. chmod 555 /etc/rc.d/test
    Install iperf package: /etc/rc.d/test is still there.
    Reinstall iperf package: /etc/rc.d/test is still there.
    Do you recall which package behaved like you describe?

#6 Updated by Chris Buechler almost 8 years ago

it was actually fixed a while back, I just missed the fact the file was still there, it's not an issue

Also available in: Atom PDF