Project

General

Profile

Bug #1736

Allow other users to be used as authenticator in xmlrpc exchanges

Added by Ermal Lu├ži about 9 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Category:
XMLRPC
Target version:
-
Start date:
08/02/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

Presently only admin user, hardcoded, can allow the sync of the user data through xmlrpc.

It would need to be done some investigation on how to allow other users to achieve this.
The username used today by xmlrpc code is only useful for HTTP1.0 authentication mechanisms which pfSense does not user anymore.

History

#1 Updated by Tommy McNeely over 8 years ago

Adding this to help prevent duplicate bugs...

In the Firewall -> Virtual IPs scree, in the CARP Settings tab, the "Remote System Username" is not used.

If the underlying system is unable to use anything other than "admin" then that field should be disabled or "hidden" until its supported.

Tommy

#2 Updated by Jim Pingle over 8 years ago

  • Status changed from New to Closed

Duplicate of #809

Also available in: Atom PDF