Project

General

Profile

Bug #1884

Lacking update validation on console upgrade

Added by Chris Buechler almost 8 years ago. Updated almost 4 years ago.

Status:
Resolved
Priority:
High
Assignee:
-
Category:
Upgrade
Target version:
Start date:
09/17/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
All
Affected Architecture:

Description

I nicely blew up a 2.0 RC box by accidentally pasting in the download URL for the iso instead of the update file in the console upgrade. Got a signature warning but I dismissed it since the update wasn't signed. For real world updates at least that should register that something is wrong. Didn't notice until it had finished, and it left the box unbootable (can't mount root, not sure exactly what it did). Need to do more validation of the update file for the console upgrade to prevent that.

History

#1 Updated by Chris Buechler over 7 years ago

  • Target version deleted (2.0.1)

#2 Updated by Chris Buechler about 4 years ago

  • Status changed from New to Confirmed
  • Target version set to 2.3
  • Affected Version changed from 2.0 to All

this needs the platform check same as manual update in web interface.

#3 Updated by Chris Buechler almost 4 years ago

  • Status changed from Confirmed to Resolved

this is fixed in 2.3 since the upgrade system's been replaced

Also available in: Atom PDF