Project

General

Profile

Actions

Bug #2010

closed

VLAN parent interface / altq interface wrong assumptions about int_family name format

Added by Andre Keller about 10 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
11/16/2011
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

Hi

I ran into an issue with vmxnet3 NICs on current pfsene-2.1 developement release.

VMware stupidly choose vmx3f as interface family name which causes pfsense to not show the interfaces of that type int the selection for parent interfaces for vlan and altq.

The problem is that pfsense uses a suboptimal regex that splits the interface index and the interface family in is_jumbo_capable and is_altq_capable. The ifindex is matched anywhere in the ifname instead of just at the end of it.

The attached patch fixes the issue. Maybe switching to preg_match as done in checking for wireless interfaces is a better way to go.


Files

int_family.patch (711 Bytes) int_family.patch Andre Keller, 11/16/2011 12:49 PM
globals.patch (812 Bytes) globals.patch Andre Keller, 11/16/2011 01:57 PM
interfaces.patch (1.02 KB) interfaces.patch Andre Keller, 11/16/2011 02:01 PM
Actions #1

Updated by Andre Keller about 10 years ago

There is another part to this in inc/globals.inc

Actions #2

Updated by Andre Keller about 10 years ago

Please Ignore int_family.patch

Actions #3

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Renato Botelho almost 9 years ago

  • Status changed from Feedback to New
  • Target version set to 2.1
  • % Done changed from 100 to 0
Actions #5

Updated by Renato Botelho almost 9 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #6

Updated by Renato Botelho over 8 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF