Project

General

Profile

Bug #2062

postfix relay package breaks system when enabled on 2.1

Added by Greg Whynott over 8 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Low
Assignee:
-
Category:
-
Target version:
-
Start date:
12/23/2011
Due date:
% Done:

0%

Estimated time:
Affected Version:
Affected Architecture:

Description

posted this on the forums.

I ran across an issue while installing the postfix-relay package today.

The package installs correctly without issue, but after you start to configure options under the 'general' tab, upon saving it loads an error page with the error:

Parse error: syntax error, unexpected '*' in /etc/inc/system.inc on line 561

we see this at line 561 in system.inc:

mail.* /var/log/maillog

at this point you can no longer use the web interface for administration of the pfsence box.

This may be specific to my setup, but aside from standard queuing and proxying, there wasn't many additions or modifications made to the original install config.

method to reproduce:

packages added to default config:

LightSquid
mtr-nox11
RRD summary
squid3
Postfix-Forwarder

Original Install was 2.0, upgraded to 2.0.1

From command line install perl ldap (/usr/sbin/pkg_add -r p5-perl-ldap) as suggested under "Recipients" tab. (intent is to use the AD to pull valid email addresses).
Install Postfix forwarder package.
From services select 'postfix forwarder'.
Click 'enable postfix' under General tab.
Click 'Outside' from Listen interfaces.
Under Logging select /var/log/maillog.
Leave all other options unaltered.
Click Save.

upon doing so you may see the parse error from above.

opening the file system.inc and removing the ^mail.* line will allow the web interface to be accessible again. any future saves under the postfix-forwarder general tab will bring back the error condition.

History

#1 Updated by Chris Buechler over 8 years ago

  • Target version deleted (2.0.1)

#2 Updated by Greg Whynott over 8 years ago

the package maintainer is aware of this and apparently there is a workaround/fix out for it.

http://forum.pfsense.org/index.php?topic=44224.0

#3 Updated by Marcello Silva Coutinho over 8 years ago

It's fixed in package v 2.3.3 since dec,21

#4 Updated by Chris Buechler over 8 years ago

  • Status changed from New to Resolved

Also available in: Atom PDF