Project

General

Profile

Bug #2115

mhash is depreciated in PHP 5.3 and must be changed

Added by Warren Baker over 7 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
01/19/2012
Due date:
% Done:

90%

Estimated time:
Affected Version:
Affected Architecture:

Description

During the General Wizard setup after you specify the password the following error is returned:

Fatal error: Call to undefined function mhash() in /etc/inc/auth.inc on line 499

History

#1 Updated by Jim Pingle over 7 years ago

mhash was supposedly moved into the base of php 5.3. Will need to see why that's missing, as it is no longer a separate module, and doesn't appear to be an option on the port that could have been disabled.

#2 Updated by Jim Pingle over 7 years ago

http://pear.php.net/bugs/bug.php?id=17828

Description: 
------------ 
mhash is deprecated and removed from php 5.3 
hash could be used as a replacement and it's provided since php 5.1

#3 Updated by Jim Pingle over 7 years ago

  • Subject changed from General Setup Wizard to mhash is depreciated in PHP 5.3 and must be changed

We only have two mhash calls, may not be too hard to convert to whatever is available.

etc/inc/auth.inc:       $user['nt-hash'] = bin2hex(mhash(MHASH_MD4, $ustr));
etc/inc/ntlm_sasl_client.inc:           $md4=mhash(MHASH_MD4,$unicode);

#4 Updated by Ermal Lu├ži over 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 90

This needs just more testing now.

#5 Updated by Jim Pingle about 7 years ago

  • Parent task deleted (#2109)

#6 Updated by Jim Pingle about 7 years ago

This should be OK with images made today. Confirmed working on new images. Must be running on images with updated PHP 5.3 from the date of this post or newer, can't gitsync up to get the fix as it's a binary change.

#7 Updated by Rob Logan about 7 years ago

yup, I was able to change the admin password and create a new user after firmware upgrading to pfSense-Full-Update-2.1-DEVELOPMENT-i386-20120226-1331

#8 Updated by Jim Pingle about 7 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF