Project

General

Profile

Actions

Bug #2380

closed

2 IPv6 nameserver advertisements fail to configure resolv.conf

Added by Seth Mos over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
DHCP (IPv6)
Target version:
Start date:
04/17/2012
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

When we get 2 IPv6 DNS servers through rc.newwanipv6 we need to explode(" ", $ENV['new_domain_name_servers']) before we check if they are valid.

Because of this no DNS servers get added to the system.

Actions #1

Updated by Seth Mos over 9 years ago

  • Status changed from New to Resolved

Fix checked in, confirmed working, populates /var/etc/nameservers_v6{$if} with multiple nameservers
Ran into broken code in our DHCPv6 server, removed.

Actions

Also available in: Atom PDF