Project

General

Profile

Actions

Bug #2686

closed

OpenVPN listens on interface address instead of VIP

Added by Cyrill B about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
OpenVPN
Target version:
Start date:
11/18/2012
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:

Description

The OpenVPN server listens on the interface address instead of the specific ip address (VIP).

In c1449c948480dd1a445a94b1aa991addd6e50e5b the required $ipaddr variable was commented out leading to this behavior. Pull request https://github.com/bsdperimeter/pfsense/pull/244/files reintroduces these variables.

However additional changes are required to enable the usage of IPv6 VIPs since the openvpn.inc differentiates between 'ipaddr' and 'ipaddrv6', while the remaining code e.g. vpn_openvpn_server.php apparently does not.

Actions #1

Updated by Chris Buechler about 9 years ago

  • Category set to OpenVPN
  • Status changed from New to Feedback
  • Target version set to 2.1

merged

Actions #2

Updated by Chris Buechler about 9 years ago

  • Status changed from Feedback to Resolved

confirmed working

Actions

Also available in: Atom PDF