Project

General

Profile

Actions

Bug #2891

closed

Limiter does not work with high speed

Added by Anders Tillebeck about 11 years ago. Updated almost 11 years ago.

Status:
Rejected
Priority:
Normal
Assignee:
-
Category:
Traffic Shaper (ALTQ)
Target version:
-
Start date:
03/19/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.0.x
Affected Architecture:
i386

Description

On 2.0.2 limiters only work up til aprox. 15Mbitps. Limiters set to speeds higher than 15Mbit will act if they are just 15Mbit. Limiters set lower than 15Mbit works just fine as expected. If limiter is removed I get full speed aprox. 60Mbit.

It has been tested on embedded Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz from Applianceshop with flash as storage.

PCU stay low so it seems not to be an issue with undersized CPU. But still it seems that the throughput through the limiter will decrease as load on the router raises. So there may be a hardware limit but probably not CPU.

Please let me know if I can help solve or clarify.

I have tried the forum before filing a bug report here.
http://forum.pfsense.org/index.php/topic,60175.0.html

Version: 2.0.2-RELEASE (amd64), built on Fri Dec 7 22:39:13 EST 2012
Platform: nanobsd (1g)
CPU Type: Intel(R) Core(TM)2 Quad CPU Q9400 @ 2.66GHz

BR. Anders

Actions #1

Updated by Ermal Luçi about 11 years ago

Probably you have to increase the queue of the limiter to hold that traffic.
Can you show an ipfw pipe show of your router when you expect more traffic speed to be passing.

Its true that limiters are cpu bound but that should not be at such low speed.

Actions #2

Updated by Anders Tillebeck about 11 years ago

Sure. I think you are just right. Command in shell is the same as "limiter info" in the GUI I guess.

Limiters:
00001: 1.000 Mbit/s 0 ms burst 0
q131073 50 sl. 0 flows (1 buckets) sched 65537 weight 0 lmax 0 pri 0 droptail
sched 65537 type FIFO flags 0x0 0 buckets 0 active

00002: 1.000 Mbit/s 0 ms burst 0
q131074 50 sl. 0 flows (1 buckets) sched 65538 weight 0 lmax 0 pri 0 droptail
sched 65538 type FIFO flags 0x0 0 buckets 0 active

00003: 15.000 Mbit/s 0 ms burst 0
q131075 50 sl. 0 flows (1 buckets) sched 65539 weight 0 lmax 0 pri 0 droptail
sched 65539 type FIFO flags 0x1 64 buckets 8 active
mask: 0x00 0x00000000/0x0000 -> 0xffffffff/0x0000
BKT Prot Source IP/port_ _Dest. IP/port_ Tot_pkt/bytes Pkt/Byte Drp
225 ip 0.0.0.0/0 10.24.0.209/0 39 13665 0 0 0
226 ip 0.0.0.0/0 10.24.0.210/0 1 63 0 0 0
228 ip 0.0.0.0/0 10.24.0.212/0 850 51688 0 0 0
249 ip 0.0.0.0/0 10.24.0.201/0 2859 4092767 0 0 0
251 ip 0.0.0.0/0 10.24.0.203/0 1 137 0 0 0
252 ip 0.0.0.0/0 10.24.0.204/0 10259 15014003 0 0 2
253 ip 0.0.0.0/0 10.24.0.205/0 213 215760 0 0 0
254 ip 0.0.0.0/0 10.24.0.206/0 23753 34084779 8 11601 0

00004: 15.000 Mbit/s 0 ms burst 0
q131076 50 sl. 0 flows (1 buckets) sched 65540 weight 0 lmax 0 pri 0 droptail
sched 65540 type FIFO flags 0x1 64 buckets 8 active
mask: 0x00 0xffffffff/0x0000 -> 0x00000000/0x0000
BKT Prot Source IP/port_ _Dest. IP/port_ Tot_pkt/bytes Pkt/Byte Drp
128 ip 10.24.0.204/0 0.0.0.0/0 4603 327528 0 0 0
130 ip 10.24.0.205/0 0.0.0.0/0 71 19407 0 0 0
132 ip 10.24.0.206/0 0.0.0.0/0 9734 528404 0 0 8
138 ip 10.24.0.201/0 0.0.0.0/0 875 36603 0 0 0
142 ip 10.24.0.203/0 0.0.0.0/0 1 89 0 0 0
176 ip 10.24.0.212/0 0.0.0.0/0 19738 26277898 1 1500 0
186 ip 10.24.0.209/0 0.0.0.0/0 422 41472 0 0 0
188 ip 10.24.0.210/0 0.0.0.0/0 3 155 0 0 0

00005: 15.000 Mbit/s 0 ms burst 0
q131077 50 sl. 0 flows (1 buckets) sched 65541 weight 0 lmax 0 pri 0 droptail
sched 65541 type FIFO flags 0x0 0 buckets 0 active

00006: 15.000 Mbit/s 0 ms burst 0
q131078 50 sl. 0 flows (1 buckets) sched 65542 weight 0 lmax 0 pri 0 droptail
sched 65542 type FIFO flags 0x0 0 buckets 0 active

Actions #3

Updated by Ermal Luçi about 11 years ago

You have only 50 slots meaning 50 packets.
Can you configure the 'Queue Size' under advanced options of limiters to something like 500+ and see if you still hit the limit?

Actions #4

Updated by Anders Tillebeck about 11 years ago

Forgot to tell that I did a total rekonfiguration but have tried to rekosntruct the limiter issue. I think you are right that the limiter is in some container with to little bandwith. I just haven't got the overview of it yet. I have just started to "go off the beaten path" with the traffic shaper.

I need three thing. I do not know if it is possible to do all.

Low prio LAN
Alias lowPrioOnLan is LAN client that should go into qOthersLow. I can let the users donwload in that queue but upload it going into normal http queue like everyone else.

Low prio WAN
Alias lowPrioServer is p2p servers. Traffic to and from this alias should go into qP2p.

Limit to 50/50Mbit pr. user
Along all the normal queues I would like to place a limiter so no user can upload or download with a bandwidth higher than 50Mbitps.

And to be honest. I can not make any of it work. Very frustrating. Hint are more than welcome.... else I will just keep trying.

Quess this bug can be closed as "not a bug". Sorry to have taken your time.

Best regards,
Anders

Actions #5

Updated by Renato Botelho about 11 years ago

  • Status changed from New to Rejected
Actions #6

Updated by Anders Tillebeck almost 11 years ago

Hello.
I would like to reopen this bug.

There is still an issue.
  1. I cannot create a limiter with 50Mbpits that allows a throughput of more than aprox. 15Mbitps each way even though it is listed as 50Mbitps in the limiter info
  2. if I change the limiter to 40Mbitps the limiter info will list 40Mbbits as expected and throughput will stay on aprox 15Mbits
  3. When adding any number to "Queue size" the limiter will stop beeing updated. If I add something to queue size and then change the limiter to eg. 30Mbitps then limiter info will keep listing 40Mbit and I cannot see any change in bucket/queue size
Another way to test is:
  1. to create a LanIn and LanOut limiter of 5Mbitps AND add 500 to Queue size to both before saving.
  2. Now add the two limiters to a rule but they will not work and not let any trafic through.
  3. also looking as limiter info will not list the limiteres (proving something is wrong)
  4. If removing the number in Queue size and savind then the limiters will work as expected. And also be listed under limiter info.

Therefor I cannot do as suggested in the original question and increase queue size as this feature seems broken somehow.

BR. Anders

Actions #7

Updated by Anders Tillebeck almost 11 years ago

This forum post is probably about same problem. But a much more detailed description:
http://forum.pfsense.org/index.php/topic,65145.0.html

Actions #8

Updated by Anders Tillebeck almost 11 years ago

Screen dumps to se symptoms

1) Create a normal limiter with queue size set under advanced settings:
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/01_lanInWithQuerySize_New.png

2) List limiter (Limiter info). No limiter show up
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/02_noLimiterInfoFound.png

3) Go back to limiter and remove queue size under advanced
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/03_lanInRemoveQueryrSize.png

4) Go back to limiter info. Now the limiter is listed
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/04_reloadLimiterInfoLimiterShowsUp.png

Reproduce...
5) go back and edit limiter. Reduce bandwith from 50Mbit to 40Mbit AND set queue size
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/05_updataLanInWithQuerySize.png

6) Go to limiter info. Limiter has not changed from 50Mbit even though just reduced to 40Mbit
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/06_limitorInfoHasNotChanged.png

7) remove queue size and save. Do not change bandwith
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/07_removeQueueSize.png

8) Go back to limiter info and see that now the limiter is updated to 40Mbit just because the queue size was removed.
https://dl.dropboxusercontent.com/u/1652656/novomatrix/pfsense_forum_pics/limiter_issue/08_correctLimiterInfo.png

Actions

Also available in: Atom PDF