Project

General

Profile

Bug #3078

NanoBSD upgrade gui confusing!

Added by GT Zenny about 6 years ago. Updated about 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
07/07/2013
Due date:
% Done:

100%

Estimated time:
Affected Version:
Affected Architecture:

Description

I think this needs to be fixed to avoid confusion whether an upgrade has been made or not.

http://forum.pfsense.org/index.php/topic,64190.0.html

Persistent in my installation.

Also it would be nice to include the changelog of every build to save the life of the CF/USB devices. Thanks for the nice work!

Associated revisions

Revision 6efe0cae (diff)
Added by Jim Pingle about 6 years ago

Make dashboard update check respect nanobsd-vga, probably fixes #3078

Revision ba581f07 (diff)
Added by Jim Pingle about 6 years ago

Make dashboard update check respect nanobsd-vga, probably fixes #3078

History

#1 Updated by Doktor Notor about 6 years ago

GT Zenny wrote:

Also it would be nice to include the changelog of every build to save the life of the CF/USB devices. Thanks for the nice work!

Github is just fine for me, except that the snapshot files should have last commit included in their filename.

#2 Updated by Jim Pingle about 6 years ago

  • Status changed from New to Feedback

I updated my ALIX and it correctly shows on the dashboard and the auto update check that it is current. The update check code is identical for both places, so I suggest you clear your browser cache and check it again.

Including the changelog isn't really possible, just look at github, it's all there. Or http://redmine.pfsense.org/activity/

The last commit is in /etc/version.lastcommit. Adding it to the filename wouldn't really help much, there is already a timestamp, adding the commit to the filename isn't as trivial as it might seem, though adding the first 8 chars of it might be feasible in the future.

#3 Updated by GT Zenny about 6 years ago

Jim P wrote:

I updated my ALIX and it correctly shows on the dashboard and the auto update check that it is current. The update check code is identical for both places, so I suggest you clear your browser cache and check it again.

Including the changelog isn't really possible, just look at github, it's all there. Or http://redmine.pfsense.org/activity/

The last commit is in /etc/version.lastcommit. Adding it to the filename wouldn't really help much, there is already a timestamp, adding the commit to the filename isn't as trivial as it might seem, though adding the first 8 chars of it might be feasible in the future.

I upgraded again, but mine is not a generic 64-bit pc. But the problem persists. It has nothing to do with browser cache, because I always browse in privacy mode without cache enabled. However, once the firmware got upgraded, one should login to gui again, so that is completely a new session which refreses browser automatically. So the problem is still outstanding.

#4 Updated by Jim Pingle about 6 years ago

  • % Done changed from 0 to 100

#6 Updated by Jim Pingle about 6 years ago

  • Status changed from Feedback to Resolved

Also available in: Atom PDF