Project

General

Profile

Actions

Bug #3203

closed

vnstat2 not working after pfsense 2.1 upgrade

Added by Kyle Janse van Rensburg about 8 years ago. Updated about 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
-
Target version:
-
Start date:
09/16/2013
Due date:
% Done:

0%

Estimated time:
Plus Target Version:
Affected Version:
2.1
Affected Plus Version:
Affected Architecture:
amd64

Description

Hi,

I upgraded to Pfsense 2.1 from Pfsense 2.0.3 and now vnstat2 is no longer working

My issue is similar to these posts:
http://forum.pfsense.org/index.php?topic=47241.0
http://forum.pfsense.org/index.php?topic=51396.0

Thank you,


Files

vnstat2 frontend issue.png (28.9 KB) vnstat2 frontend issue.png vnstat2 frontend issue Kyle Janse van Rensburg, 09/17/2013 02:39 AM
Actions #1

Updated by Kyle Janse van Rensburg about 8 years ago

Hi,

I have done a new install and it looks like it's broken there as well.
When I click vnstat info and hit save on the relevant interface I get the following error:

Error: Unable to open database directory "/var/db/vnstat".
Make sure it exists and is at least read enabled for current user.
Exiting...

To solve this I created a folder called vnstat and ran the following command:

vnstat -u -i re0

That looks like it solved the backend, but the frontend is still broken.

Actions #2

Updated by Kyle Janse van Rensburg about 8 years ago

Hi, I was able to fix this using this guide if anyone runs into the same issue.

http://forum.pfsense.org/index.php/topic,51396.0.html

I am using a 64bit system so the symlink looks like this:

ln -s /usr/local/etc/vnstat.conf /usr/pbi/vnstat-amd64/etc/vnstat.conf

At the pacth section leave everything default and enable auto apply patch

Wonder if this patch will be pulled into the main repo someday?

Actions #3

Updated by Kyle Janse van Rensburg almost 8 years ago

Hi,

This is still broken in 2.1.1 Pre-Release

Beginning package installation for vnstat2 .
Downloading package configuration file... done.
Saving updated package information... done.
Downloading vnstat2 and its dependencies...
Checking for package installation...
Downloading http://files.pfsense.org/packages/amd64/8/All/vnstat-1.11_1-amd64.pbi ... (extracting)
Loading package configuration... done.
Configuring package components...
Additional files... vnstat_php_frontend-1.5.1-updated.tar.gz failed.
Backing up libraries...
Removing package...
Starting package deletion for vnstat-1.11_1-amd64...done.
Removing vnstat2 components...
Tabs items... done.
Menu items... done.
Loading package instructions...
Deinstall commands... done.
Removing package instructions...done.
Auxiliary files... done.
Package XML... done.
Configuration... done.
Cleaning up... done.
Failed to install package.

Installation halted.

Let me know if I need to provide more details

Actions #4

Updated by Bryan Paradis almost 8 years ago

I have updated the package again and moved away from the previous package + archive. Should work fine now.

Actions #5

Updated by Chris Buechler about 7 years ago

  • Status changed from New to Resolved
Actions

Also available in: Atom PDF