Project

General

Profile

Actions

Bug #3294

closed

Creating users/groups silently fails on read only filesystem

Added by Phil Sweeney almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
User Manager / Privileges
Target version:
Start date:
10/26/2013
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
2.1
Affected Architecture:
All

Description

Was setting up VPN and following various guides, which included the creation of a group and a user.

I did this, and it was all reported fine, however when I looked at the systemlog it reported an error due to filesystem being readonly.

To clean it up I had to remount as R/W, delete the user and groups, and start over.

Actions #1

Updated by Renato Botelho almost 8 years ago

  • Target version set to 2.1.1
  • Affected Architecture All added
  • Affected Architecture deleted (amd64)
Actions #2

Updated by Renato Botelho almost 8 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Ermal Luçi almost 8 years ago

The commits are wrong in my opinion!

Why should backend code have to deal with mounting the disk.
I sept a lot of time before on having this cleaned up and now you are adding things back again :)

Actions #5

Updated by Phil Sweeney almost 8 years ago

When I reported this I was probably more expecting some error handling to be added so it actually failed properly and told you the error rather than just pretending it worked, but up to you guys :)

Actions #8

Updated by Renato Botelho over 7 years ago

  • Status changed from Feedback to Resolved
Actions

Also available in: Atom PDF