Project

General

Profile

Actions

Bug #3555

closed

Editing firewall schedules is seriously buggy

Added by Doktor Notor over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Web Interface
Target version:
Start date:
03/29/2014
Due date:
% Done:

100%

Estimated time:
Plus Target Version:
Release Notes:
Affected Version:
All
Affected Architecture:

Description

Forum thread: https://forum.pfsense.org/index.php?topic=74101.0

Even after some previous fixes
- clicking edit on Configured Ranges (under Schedule Repeat) still freezes the browser.
- additionally, even if I clear the days selection, the cleared days gets still added to the range. E.g., select everything Mon - Sun, then clear Sat and Sun, add some hours range, click Add Time. The range says Mon - Sun.

Actions #1

Updated by Doktor Notor over 7 years ago

Additionally, upon deleting the buggy schedule (example two above), the selected days stays selected, however when you try to re-add the schedule (e.g., only change the hours), you get "You must select at least 1 day before adding time" error popup. Then you need to deselect all "selected" days, reselect again, then it finally works.

Seriously, getting a dropdown list instead of this "fancy" buggy calendar would seem to be a whole lot better, not to mention, the Month dropdown that lets you select 12 upcoming months just makes no sense whatsoever.

Actions #2

Updated by Doktor Notor over 7 years ago

And yet another one. When you select Start Time ending with 00 Min, click Add Time, the Min dropdown gets empty, then you select some other day, again click Add Time, you end up with some invalid junk missing minutes altogether.

Actions #3

Updated by Renato Botelho over 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100
Actions #4

Updated by Doktor Notor over 7 years ago

OK, after gitsync, all fixed except for the issue described in the last comment.

Actions #5

Updated by Renato Botelho over 7 years ago

I couldn't replicate this one, what browser/version are you using?

Actions #6

Updated by Doktor Notor over 7 years ago

Well, that one is broken at least in Chrome 33+ and IE11. Does not happen in FF (27/28).

Actions #7

Updated by Renato Botelho over 7 years ago

  • Status changed from Feedback to New
  • % Done changed from 100 to 80

On Chrome I was able to replicate, will work on a fix

Actions #8

Updated by Renato Botelho over 7 years ago

  • Status changed from New to Feedback
  • % Done changed from 80 to 100
Actions #10

Updated by Doktor Notor over 7 years ago

Fixed in Chrome and IE as well here. Thanks!

Actions #11

Updated by Renato Botelho over 7 years ago

  • Status changed from Feedback to Resolved

Thanks

Actions

Also available in: Atom PDF