Project

General

Profile

Bug #3727

PPP config loses "on-demand" setting when configured via interfaces tab

Added by Vick Khera almost 4 years ago. Updated over 3 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
-
Category:
Interfaces
Target version:
Start date:
06/30/2014
Due date:
% Done:

100%

Affected Version:
All
Affected Architecture:

Description

I configured a PPP interface to run a verizon LTE modem plugged into a USB port. It is assigned as "WANVZ"

If I go to Interfaces -> assign -> PPP -> edit my VZ modem, in the advanced tab I can set dial-on-demand and set the timeout to 120 seconds. This seems to work ok.

If I go to Interfaces -> WANVZ, and I click save, the on-demand settings are erased.

I think this is a bug, as it silently removes an important setting.

Based on discussions with jimp in support ticket IAV-77363, I believe that the WANVZ interface page is causing blank values to be stored for the items in the PPP Advanced settings.

ppps-edit-diff.png (79.7 KB) Chris Buechler, 10/16/2014 12:46 PM

Associated revisions

Revision 4703c007
Added by Ermal Luçi over 3 years ago

Fixes #3727 Do not unset ondemand for ppp type interfaces since it is controlled here only for pppoe/l2tp

Revision c4642eb1
Added by Ermal Luçi over 3 years ago

Fixes #3727 Do not unset configuration values from ppp config if not needed.

Revision e840fc8c
Added by Chris Buechler over 3 years ago

Don't unset these items for PPP configurations as they're not configured here and doing so loses settings configured in interfaces_ppps_edit.php. Ticket #3727

History

#1 Updated by Chris Buechler over 3 years ago

  • Category set to Interfaces
  • Target version set to 2.2
  • Affected Version changed from 2.1.x to All

confirmed

#2 Updated by Ermal Luçi over 3 years ago

  • Status changed from New to Feedback
  • % Done changed from 0 to 100

#3 Updated by Chris Buechler over 3 years ago

that didn't fix it. Config diff attached that shows changes made by interfaces.php just clicking "Save" on an assigned PPP without changing anything.

#4 Updated by Ermal Luçi over 3 years ago

  • Status changed from Confirmed to Feedback

Last push behaves better for me.

#5 Updated by Ermal Luçi over 3 years ago

#6 Updated by Chris Buechler over 3 years ago

  • Status changed from Feedback to Resolved

no change with Ermal's last commit.

My last commit on this ticket resolves this for ondemand and some other items that would be incorrectly unset for PPP.

Also available in: Atom PDF